Stonehearth won't recognise my main graphics card

I’m running on a laptop with an NVIDIA GeForce GTX 870M, but when i launch the game and go to settings it’s not recognising that card, it’s only recognising my Intel HD Graphics 4200, which makes the game seriously laggy. How can i get it to recgonise my NVIDIA card? I’m assuming this is the issue with the lag since i can run intensive games (Rome II Total War and ARMA 3) on max settings easily using the other card.

hey there @185000a … welcome aboard! :smile:

there are a few experts here who can provide better assistance that I can, but in the interim, have you take a look at a few articles like these?

my partner in crime @geoffers747 had this suggestion, over on this thread:

I know with my laptop I can simply right click the desktop icon of the game and choose the graphics processor - you might need to use the humble version for this, not sure.

Thank you for your reply! I worked out a way to fix this by going into the NVIDIA Graphics Control Panel and telling the game manually to use the NVIDIA card.

Game is crashing every 5 minutes though, but at least i can play it now! :smile:


The game says i have Inter® HD Graphics 4600, although i have GTX 860.
It should work perfectly, yet at some point when i have 16+ settlers it just stops. I didnt try the alpha 10 (maybe it was resolved) but the fact it doesnt recognize my GTX annoys me.

I’ll toss some threads to see if they can help you. If the problem persists, we can page more people that could help you.


Thanks! Now it does recognize my graphics card. if ill get those crashes again ill probably seek help in a new post!

1 Like

I’m glad it worked :smile: