Some of my custom trees aren't appearing in my custom biome

I’ve been trying to make a jungle biome, which obviously includes a lot of new trees. However, a few of my trees don’t seem to be appearing. Here they are:

  • Brazil Nut Tree
  • Small Fig Tree
  • Large Nutmeg Tree
  • Medium Fig Tree (does appear, just very rarely, which is not intended and I don’t know how to fix it)

I can’t seem to figure out what’s going wrong, and the biome config files are commented quite poorly, so I have absolutely no idea how I might go about fixing this. Could someone with more modding experience than me please take a look at this and see what’s happening?

Here’s the mod: ems_biome_jungle.smod (144.6 KB)

1 Like

@BrunoSupremo may be able to help, if he has time. I’m not very good at the whole mod making thing, but Bruno comes highly regarded in that area of expertise & I don’t really know many other Modders on this site yet.

wow you have alot of trees in there :slight_smile: :sunny: I dont know exactly what is going on, but i tried to stamp a large brazil nut tree into the game, and it would not do that…

So to me it seems like it is something with the entity itself?

Bruno might have a better understanding on what is going on :slight_smile:

Good job on this biome, i looove that it has so many different species of trees :heartpulse: :merry:

Pretty sure it’s something with how I exported the QB files, as those two trees were the only trees I exported from VoxelShop after resetting my settings to make it run again.

1 Like

Welp, I figured it out.

Turns out that Stonehearth doesn’t like its tree QB files having multiple layers. For some reason, my files had some extra layers, so I had to delete those to get it to work.

I guess now I can finally continue the project…


Awesome. Can’t wait to play your Biome.
A Jungle themed Empire sounds like an Awesome Project to work on & Having a Jungle Biome makes that much easier to accomplish.