Single block mining bug

resolved

#1

Summary:

The mining tool, the one that you can use to mine out individual blocks doesn’t work, or rather my hearthlings don’t respond to it at all. Sometimes when I load in a world with this type of mining pre inputted it works, most of the time it doesn’t.

Steps to reproduce:

  1. try mine out a single layer

Expected Results:
a hearthling to mine out a single layer
Actual Results:
nothing happens
Notes:

Attachments:
also :slight_smile:


Version Number and Mods in use:
A16 unstable 2922 no mods
System Information:


Hearthlings / Ladders
#2

i thought i had replied to this after tagging, but apparently not… :sweat_smile:

anyways, i’ve also run into this problem, luckily Yang said on stream this morning that some mining bugs have been fixed for the next build, so hopefully this one is included in those fixes.


#3

I’ve had no problems using the small mining tool (A16 r2924).

Can anyone affected confirm that it’s fixed (or not) ?


#4

seems to be fixed for me, after loading my save up in 2924 they immediately went and mined out the single block stuff they refused to mine earlier.


#5

yeah it was fixed in 2924 it only didn’t work in 2922.


#6

Why do i have to put the ladders everywhere? They do nothing ( like mining ) until i put a ladder every 2 blocks.

And i also havent seen any of the new monsters yet.


#7

That part about mining doesn’t sound right. But I noticed slightly wonky behaviour with mining as well, so it’s possibly a bug. A screenshot might help, though.
About the new monsters: How big is your settlement and how many Hearthlings have you got? I think the harder ones only attack after you’ve reached a certain size.
And just to make sure: Do you have Alpha 16 Beta installed in the first place (upper right corner shows the build number if you’re unsure)?


#8

about 12 hearthlings and yes i have alpha 16. Screenshot wont help they just sit and do nothing


#9

I see. Sounds like a bug then. In my case, the aforementioned problems with Hearthlings refusing to mine ceased with release 2924. Did you try that one out already?


#10

nah not yet. i will try it


#11

I had a problem mining in the new unstable branch also when doing my initial groundbreaking with single blocks, and i had to use ladders even when i had dug navigable steps. Once I got the mine established and was using four tile block.mining those problems went away though.


#12

@Darkbleadx , @Hieronymous, have you tried in the build that @SachielMF mentions?
It seems to be fixed on it.

(Note to self: merge with Single block mining bug later if it deems to be the same issue).


#13

I haven’t run into the issue in the latest build, no. On the other hand I haven’t been doing the same things.


#14

yes it worked. thanks