Second floor not building correctly

second floor not building correctly
attempted to add second floor to building however walls ended up only on horizontal sides and were not removable.
Steps to reproduce:

  1. add second floor
  2. add walls to second floor
  3. ???

Expected Results:
walls on both vertical and horizontal sides (when viewing from front)
Actual Results:
walls on only horizontal sides (front and back)
could not take screenshot due to game crash soon after

Versions and Mods:
latest version
System Information:
windows 8 surface pro 3

Hey there @ZebZeb, welcome to the Discourse! Thanks for using the bug report template.

Multi-story building is definitely a bit buggy right now, but I have not heard of it crashing the game! Let me page @Albert and @not_owen_wilson to see if this is a known bug…

Can you provide any details on the building you were adding the floor to? Was it fairly regular (square/rectangular foundation) or did it have a “different” design?

thanks for the quick respond!
it is the same design as the shared sleeping quarters but a bit bigger. I am in the forest biome and only an hour or less into this game. I tried restarting the game and have been getting an “engine error” message now but the game is still playable.

OK, an engine error is likely to be very helpful! Can you copy and paste the error(s) here?

naturally it isn’t showing the error when I restart the game now -_- but I did take a screen shot of it the last time. maybe it will help a little bit?

1 Like
develop-2733 (x64)
.../components/entity_forms/entity_forms_component.luac:178: attempt to index field 'ai' (a nil value)
stack traceback:
    [C]: ?
    .../components/entity_forms/entity_forms_component.luac:178: in function '_reconsider_entity'
    .../components/entity_forms/entity_forms_component.luac:126: in function '_cleanup_item_placement'
    .../components/entity_forms/entity_forms_component.luac:23: in function

found it!

1 Like

Did you by chance interact with a trader around the time you received this error?

it was about ~4 minutes after this time but the other cases I got the error immediately after opening the game.

OK, the engine error might not be related to the building error then…that error has been reported before, but it is good to know that it still exists:

1 Like

I got this error again and was able to take the screen shot this time

I also got this error shortly after not sure if it is related or not…

release-489 (x64)
stonehearth/components/wall/wall_component.luac:106: attempt to index a nil value
stack traceback:
[C]: ?
stonehearth/components/wall/wall_component.luac:106: in function ‘connect_to_columns’
stonehearth/services/server/build/build_service.luac:234: in function ‘init_fn’
stonehearth/services/server/build/build_service.luac:123: in function ‘_create_blueprint’
stonehearth/services/server/build/build_service.luac:234: in function ‘_create_wall’
stonehearth/services/server/build/build_service.luac:232: in function ‘_add_wall_span’
stonehearth/services/server/build/build_service.luac:199: in function ‘visitor_fn’
stonehearth/lib/build_util.luac:270: in function ‘grow_walls_around’
stonehearth/services/server/build/build_service.luac:199: in function ‘grow_walls’
stonehearth/services/server/build/build_service.luac:189: in function ‘cb’
stonehearth/services/server/build/build_service.luac:304: in function ‘do_command’
stonehearth/services/server/build/build_service.luac:189: in function <stonehearth/services/server/build/build_service.luac:188>

Hey again @ZebZeb, can you by chance save that building as a template and upload it here?

I believe this is what you are looking for:

(Your uploader doesn’t allow for .json files)

That would be it, thanks!

Yeah…I should ask @sdee or @brad about that. Not sure if there is a security risk for allowing a .json file from being uploaded. Regardless, the way you uploaded it is fine, or you could compress the .json as a .zip and upload it directly…

okay well…
created a new game and tried again however this time I attempted to use the free wall tool instead of the auto wall tool. it worked except for one part and made the roof funny looking so I clicked undo and it broke. I am uploading the error, the log and a screenshot.

wall and roof (856.1 KB)


1 Like