Save Missing / Startup Bug

I was playing for a good 4 hours, First time I’ve played going well… Saved the game and Exited Stonehearth
which cause a Reference Error BlueScreen, My computer froze, and I rebooted
When I started it up again today, I got invalid characters in the user_settings.json, So I opened it up. Saw that it was Null Filled. Deleted the file and started stonehearth again, Works this time but no more save games
Save Game files still exist in the Saved_Games folder,
Thinking it was a reference to the save game I created a new world and saved it and quit, No Bluescreen this time.
Start it up again, The new game is in there to load but the old isn’t. So not reproducible currently… But was my first time i’d played

Steps to reproduce:
Can’t seem to.

Expected Results:
Keep my save game, Not have to understand how software works to delete a borked settings file.

Actual Results:


Error from the log re JSON
2016-07-02 09:34:37.232150error parsing json: Invalid JSON character detected (lo)

Version Number and Mods in use:
No Mods

System Information:
Windows 10

Major Minor Build Revision

10 0 10240 0

Further to this… I looked into the save’s JSON files…
Found the first save is also all Nulled Out…
Tried copying the Structure from the other save game, But i’m missing something, Probably around the buildings
It just restarts back to title on the “Corrupted” save I edited.

I just got this exact same error. Don’t know why. It happened after I crashed the game and had to shut down and reboot my computer. I tried deleting the local content and redownloading and installing the game, but that didn’t help. I also tried ridding myself of some old saves and my most recent save, but that didn’t seem to work either. Very bizarre :confused:

So I finally found something that seems to work. I had to delete the entire Stonehearth folder from steam > steamapps > common, delete the local files in Steam, and then reinstall from there. Hopefully it’ll stay fixed.

Edit: After some more tinkering, I figured out it’s not the save files; it’s one of the saved objects