Rugs being removed by workers after placing in world

Bug: Fur Rug stuck in a loop

So when you place a fur rug in say a tiny cottage, it would get placed, but then a different worker will then come and collect it again and put it back in the stock pile (where it actually disappears). You can place one fur rug - anything after that will be picked up by another worker

Steps to reproduce:

  1. Place one rug (works fine)
  2. Then tried to place a second
  3. Watched as rug was placed but was then picked up by a different worker

Expected Results:
More than one fur rug should be able to be placed.

Actual Results:
Any fur rug after second placed will be picked up again by another worker

Versions and Mods:
Release 472 (Alpha 12)
Mod: Stonehearth Cafe ( [MOD] Stonehearth Cafe (Cooking And Farming Expansion) 1.92 )

1 Like

Hey there @Woopdecker, welcome to the Discourse!

First, awesome use of the bug report template! It really helps the developers to recreate the issue quickly. I am going to page @Albert for you as this sounds like an AI issue.

Hey @jomaxro, thanks for the speedy reply. Certainly an interesting bug! Thanks for getting on it so quickly!

ill try to see if this happens once I get my houses started the ones with the fur rugs

Confirmed. It actually happens with just one rug as well. I’ll get this fixed. Thanks!


Was just coming in to say that my wife and both reproduced this one on our two different machines. Great to hear it was a clear problem! :smile:

Woohoo :smiley: Now ALL my hearthlings can have a nice cosey rug in their house :smiley:!

Thanks guys, devs on this project are ace



I know this was mentioned tangentally in another bug report but it didn’t look like it was addressed. I’m finding under some circumstances that hearthlings will not let sleeping rugs lay and will pick them up and put them back in stockpile. This seems to happen when the rug is within any kind of proximity to any other items (Such as tables, chairs, doors and other rugs) so that if they are underneath or directly beside them they are picked up again.

The Game is already 26 days old and I’ve found myself having to reload a few times already to un-stick annoying AI glitches but reloading didn’t help this one.

I was having this problem as well just a couple days ago. When I noticed them placing the rugs and then picking them back up right away I tried placing several out in the open away from anything else. Same result.

Thanks for the reports. This has already been fixed and will be in the next build.