[Res] Highlighting/Selection Error

Hey there,

Whenever I hover over any entity, a new red error line pops up. there is no highlighting going on and I cannot click anyone or anything. This happens from startup, with a million of different settings and even when I switch between Graphics Cards. This has been happening since Alpha 10 Steam release, and persists through latest build (A10_5-3). I am not using any mods or the like.

Steps to reproduce:
I’ve no idea how to reproduce this, it just happened since steam release.

Expected Results:
Whenever I hover over an entity, it highlights and I can click it and do what I am able to do with it. for example, I should be able to click a carpenter and let him build a workshop.

Actual Results:
Whenever I hover over an entity, there is no highlight effect going on and I cannot click it. every entity I hover over, spawns a new error line in the red

System Information:
Windows 8.1.1
Intel i7 4790K
Graphics Cards used: Nvidia GTX760 4096MB/Intel HD Graphics 4600
16GB DDR3

Notes:
Here’s the error code, since I cannot upload an image:

Summary
No matching overload found, candidates:
void hilight_entity(lua_State*,luabind;;object,Point3&

Backtrace
stack traceback:
[C]:?
[C]: in function ‘hilight_entity’
…ehearth/services/client/hilight/hilight_service.luac:29: in function ‘_on_frame’
…ehearth/services/client/hilight/hilight_service.luac:8: in function <…ehearth/services/client/hilight/hilight_service.luac:8>

category
Severe


Have you tried the workarounds from the Current Workarounds thread? Just taking a stab in the dark, but it might be a problem with the current install. If so, verifying the integrity of the game cache through steam may help.

I’ve tried those, yes. But unfortunately they did not do the trick.

Are you able to upload an image to imgur or something like that and link it here?
Also, can you grab your stonehearth.log (from your stonehearth folder) and upload or copy/paste it here?

1 Like

I’ll try to do that later today.

It’s gone, and I have no idea why. anyway, here’s the image:
http://imgur.com/gallery/0mK7Ehx

EDIT: By gone, I mean it is suddenly no longer an issue.

Have you done anything special, like reinstalling game or something?
We don’t know the cause of the error, and I’m glad that you don’t have it anymore and that you can play now, but maybe some day some other user will find the same error, and I shouldn’t tag it as resolved, perhaps :disappointed_relieved: .

Since the request for the image I’ve only restarted the game, so I really didn’t do anything new. No hardware changes, no software changes, nor OS updates or graphics card updates. So I really have no idea why it suddenly works

Hmm… :confused: Maybe something got loaded wrong.

Yeah might be, but i had the bug throughout restarts of my system, deinstallation of stonehearth and hardware changes, but this afternoon it just worked, and kept working. So it’s really odd.

1 Like