R210 Building Menu Broken

While trying to build a roof or remove a building C++ error appears.

well, technically the error is lua-related, but the exception is thrown by c++…

I think I read a report from February which complained about not being able to build roofs, too.

You just made a custom building and when you clicked to generate the roof, it threw those errors, right?

There are several issues concerning the building editor right now…

As always, thanks for reporting :smile: !!

2 Likes

Thanks for the reply, wasn’t sure, this post may now be locked in 3…2…1

Not yet!!! :anguished:

2 Likes

I love this game very much, and for the first time I got so frustrated I actually rage quit Stonehearth today. I tried to make a simple house and errors just started occurring. First off the undo button is broken, once I figured that out I decided to remove the building… Nope, not today said the game. The game then let me place windows and luckily the erase tool was working, so I decided to let the show roll on and erase some of the miscalculated windows. After I was done fixing my mistakes I decided it was time to place a roof, as soon as I clicked on the roof selection tool and my building all hell broke loose. The red screen to the right hand side of me was flashing with right text reading “Null value” I panicked! All my hard work of getting this building into this game, gone. I just wish someone would work on the building system… That is all.

I’m sorry to hear that, @Feashrind

Could you elaborate a bit? It was the first custom house you tried to do in that game?

I’m having trouble reproducing. I’m getting errors when I click the undo button after modifying height of the roof, for example (but I can undo the placement of a floor without any problem).

Also I can click the remove building button and it will work correctly.

Here’s the result.

  1. Created building
  2. Added windows and door
  3. Try to add roof.
  4. Result, errors
  5. Rage.
1 Like

Yuck–and yikes! If you build doodads after raising the roof, you’ll avoid this bug. Guess I should start placing furniture before I build the roof. Fixed for the next build. Thanks for the detailed report!

2 Likes