Bug: Roof editing / undo

In build custom building mode, I placed a roof on the building then removed it by using the green undo button. Then when I clicked the N W S E buttons to change the direction the roof was facing for when I replaced it and when I tried to put the roof back on it didn’t work and I got a couple of error messages.
The first error was: stonehearth/services/server/build/build_service/luac:318:attempt to call method ‘get_component’(a nil value)
Then lua runtime error.

Hope this helps you fix it :smile:

I get this too, it really bothers me because I can never make up my mind on what roof I want to be :stuck_out_tongue:
But when this happens, the building design becomes useless, since it refuses to change roof direction and roof material.

Please fix :smile:

Hey guys, i’ve been experiencing this for the past few alphas, but when building my houses, my game gliches out and shows all these red error codes when i edit my roof in the build mode.
This can be solved by saving and restarting the game but it gets pretty annoying

Steps to reproduce:

  1. Create roof on building
  2. undo, and create another
  3. change the roof directions ( NESW)
    Or. 4 Change roof height
    In Alpha 8 changing the roof material is fine
    It usually bugs out at step 2 - 4