Placing the camp standard

So as it is now, when you have finnished a building or construction and want to place an item in or on that, it automaticlly renews the list of things needed to finnish the building?
Basicly the heartlings need to get the things from a stockpile. Its not very clear and sometimes result in them taking a new crate from the stockpile instead of moving the actual crate with goods in that you want them to? This can then be worked around by emptying out the intended crate over to the new one, but it dont feel like it works like intended?

The worst situation is if you try and place the campstandard on or in a newlybuild construction! it wont happen and the ghost of the standard will never disapear. Could we not get the option to put the standard in a stockpile?

The camp standard cant be undeployed. it’s a permanent part of your town, what your describing though is a known bug with the building editor where in, if you try to move something inside a building before it’s actually (fully) completed, it’ll make a ghosted item without actually issuing the move command to the item in question. the easiest solution to this is to make sure and click the building and see that it isn’t needing any items and has had all the scaffolding gone before moving your camp standard (or anything else) in. :slight_smile: will fix a lot of the headaches I promise you.

Yea, my suggestion was just to get a solution to the one item that cant be worked around with this bug… And i have tried this with completely finnished building aswell… I dont see why the camp standard cant be undeployed? Maybe if it werent placed, we just didnt get any merchants or traders comming by?

Of course the best solution would be to get the last few bugs in the building department out of the way :wink:

1 Like