Pet are always "away from town"

After the loading in multiplayer all of the pets in my city get status “away from town”
Steps to reproduce:

  1. Connect to the other player in multiplayer
  2. Build city with pets (in my last case - fox)
  3. Exit the game
  4. Connect again

Expected Results:
Pets walk, sleep and eat when they’re hungry
Actual Results:
Pets are stunned and have status “away from town”
The status remains until they die of starvation. Reloading and teleporting don’t help

Version Number and Mods in use:
No mods, 1.0
System Information:
Windows 10, 64bit

We fixed this very recently, not sure if the fix is in the stable branch or only in the unstable :thinking:

1 Like

like i know the stable and the unstable are the same version at the moment :wink:

1 Like

It might not be fixed for previous savefiles, then. I’ll double check.

1 Like

Hey just wanted to butt in and say i have the same issue, and im using the unstable branch with a new world, pets wont move, it seems they are hungry but do not die too

Could you upload the savefile from the host where this issue is happening? We’re having trouble reproducing this.

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.
1 Like

Here it is. Sorry for a delay.


Thanks for the savefile, @Sherlock_Rose.

Is there a way to reproduce this consistently? We’ve tried the steps from the OP but they pets are fine.

In the savefile from Sherlock_Rose, the pets are away from town but it would be nice to know how did it happen.
Did the host save while the client was connected or disconnected? Did the host save/load several times? Did the issue start to happen after the first reconnection from the client, or at a later reconnection?

It’s very confusing because this bug is supposed to be fixed since the build after r887 (we’re currently in r893) :confused: : [r887] Pets and shepherded animals are "away from town" after rejoining multiplayer server

If I remember well, the game was saved while I was connected. Host saved/loaded several times, but with no success. The issue started to happen early. but not after the first reconnection.

P.S.: Several times my pets were alright after the reconnection, but the issue appeared again. If you need tha savefile made when I was truly connected or not, let me know.

Thanks for your trying to help!

1 Like

Hello there! I am the host of the savefile that @Sherlock_Rose was talking about. We just tried the following steps and pets seem to be fine now:

  1. I loaded that savefile.
  2. Cliend connected, his pets were still away from town.
  3. I saved the game, did not pause it (normal speed).
  4. Loaded that save and waited for client to join again, without pause or any actions on my side.

I hope that saving the game (New save, not Overwrite) and loading that new savefile solved the issue.

BTW that exact save attached in the topic seems to be the “bad” one, because when we tried to load some previous savefiles, pets were ok. I guess something went wrong, but I have no idea what exactly.