[NLA] Pathfinding still can cause game stutters


#1

On my computer

The path-finding sill can cause very fast game freeazes which go away after like a quarter of a sec (or less (usually less))(pathfinding takes up whole bar or 1/5th during that time), no matter how many people are pathing, it can be annoying, it is barely noticeable when not moving however when moving you get a noticeable-enough to be strange freaze)
I hope you guys keep working on pathfinding.
Just thought I would stay it is still happening (albeit it happens less, but it still happens)
and
Yes my drivers are all updated.
and the game runs smoothly at over 100 fps otherwise, which is why it is strange.

Perhaps I just get annoyed easily, but I thought you should know.


#2

Quite possibly :stuck_out_tongue:

I very much doubt pathfinding is completed, I know this is one of those annoying and tiresome things but … it is very much still alpha.

Unfortunately we all have to sit tight, and wait for our glorious Radiant overlords to fulfil our pathfinding needs (and every other need we might have, apart from that one, definitely not that one).

On a serious note, it’s still useful to post things like this so they can gauge who is experiencing what so thanks :slight_smile:


#3

I hope so, I may have downplayed it a bit, but the stutter can be annoying sometimes.
It is just strange. For example if I have a fps check thing on, the fps stays constant during the stutter.
(as in, it isnt changed by the stutter)
and it makes the camera jump when moving (which is why you notice it while moving the camera)
And the game runs at a decent 120 fps otherwise.
albeit the stutter doesn’t happen all the time. (the infrequency of it aids in the annoyance)

edit:
It happened and it caused my carpenter to repeat the grab the saw animation.In addition to causing a momentary freeze.
It is definitely a bug.If it wasnt obvious already.

edit 2: This just keeps getting weirder.
Ok, so I am not sure if this is related, but, the game just froze, possibly due to this bug, but longer then the rest), and during the freeze I was ABLE TO ROTATE THE CAMERA WHILE IT WAS FROZE no problem…


#4

Tom stated that this release would be very CPU intensive as the AI keeps looking for tasks to do very rapidly. However now they are working on the scheduler that’ll cut down the amount of looking the AI does.


#5

um, I was able to rotate the camera during teh freaze and my framerate was still 120 fps. So you are misunderstanding me. If it was a cpu problem, everything including the camera would freeze.


#6

Ahhh only skimmed the first few paragraphs of your post . . . :fearful:


#7

have you queued up a number of tasks? stutter steps were anticipated/expected though, based on what the team has communicated…

but as @Geoffers747 mentioned, this will be one of those fundamental systems that is continuously fine tuned…


#8

having 1 task can cause a stutter in this case. (right when i order it ) no matter how much is going on, Its very strange given how powerful my computer is.
Like I said, in one case I was able to move my camera during a long stutter. And noticed that everything had frozen except the camera, and that I was still running at a solid 120 fps.

This is an obvious bug and has nothing to do with the CPU.
(and no the blue bar was not taking up the thing)

It is something else that needs to be looked at.

I haven’t seen others complaining about this (except on the stonehearth guru forum) so I think it may be an incompatibility with my TOSHIBA laptop.

Its not game-breaking (for the most part)
But it can be very annoying. (when it happens)
And I really hope it is looked at.


#9

When shall we three meet again?
In client, server, or in-game?

Server, where the AI magic happens, and client, where the camera stuff happens, are separate entities. It’s completely possible - and happens quite often actually - that the server one freezes for whatever reason. It’s also possible for the server state to break completely. In that case, nothing but the camera movement/rotation works.

Taking a look at the task manager, having Stonehearth running at 25% is a tiny bit worrisome. Especially since that’s about one full core here I believe…


#10

Well I hope they fix it.
(It didn’t completely break, it unfroze less then a second later)
(and yes my computer is defiently powerful enough to run this ) Like i said it runs at a consistent 120 fps.

They really should fix this.


#11

It stutters all the time. It’s not worthy of reporting because it’s a well known issue (that they’ve already said so), has been since the first Alpha and is still in development - i.e. there’s going to be some changes at some point.


#12

So I am not the only one with this issue?

This stuttering doesn’t appear to have anything to do with the ai “Thinking” as no the blue is not taking up the entire thing when it happens. (or even a 4th of it) (Like i said it also stays at constant 120 fps) (though sometimes it is)

Also the fact that a game is still in development is no excuse to not report a bug. As they need to know about it to fix it.And the stuttering I get appears at least partially unrelated to the ai “Thinking” (of course it could be, (even though it doesnt appear to be) and i didn’t see it reported.

I am just being thorough.


#13

From what I can tell, the bars are not too representative. Because…

That’s nice, but FPS has nothing to do with it. You can have an endless loop on the server and still get a bazillion FPS. Again: The client doesn’t care. It’s decoupled.

As a fun fact: If the server is hanging, your bar isn’t updated either. Once it becomes updated you might see a little flash for a frame or two before it normalises again. It’s not representative for complete freezes.

Agree with the first part, disagree with the second. Their blog reads

Game may stutter when lots of commands are issued. (This is the result of everyone “thinking” at once.)
Game may pause for a few seconds after putting down a wall loop or simple room blueprint

so they are very well aware of this issue right now.


#14

MY god, I already said i am not issuing a ton of commands when this happens. It literally only requires ONE command and it stutters when you make the command.(not all the time) I’m talking NOTHING but a single command to go to a tree.
Which is strange.

(Note again it isnt happening all the time,)

I am convinced this is separate from the issue posted on the dev blog…


#15

Even though you are only issuing one command, the game is running more. There are 26 possible AIs active in a normal worker - a few of them even if there’s absolutely nothing going on. AIs to simulate boredom if you want to. As soon as you throw in just a few things - a single log might be enough - it may escalate.

The weaker your machine, the worse this will end. What might not result in a stutter (and merely a spike if even) on medium/high end machines can easily bring down weaker hardware.


#16

My hardware is high end.And there is no question as to the fact that it IS high end.

Look at my specs.which I stated in the OP. Which brings me back to the constant 120 fps.

-_-

WHICH IS WHY THIS IS SO DAMN STRANGE.

But yea, its a stutter, nothing more, and sometimes I never get stutters, But it happens.sometimes.And when it does, it is annoying.

Why are you so bent to say that it is a problem on MY end when it IS NOT.

It obviously isn’t on my end, It is a bug.

This same laptop is plenty powerful enough to run skyrim with best possible graphics with no loss in framerate.
Minecraft at 300-400 fps with highest graphics.settings.


#17

Okay, this is getting ridiculous. If I wish to speak to a wall, I’ve got four nearby that are probably more eager to listen. So, last attempt.

Your FPS are absolutely irrelevant for this issue. The game is split in two parts: The server and the client side. The server side does about every possible calculation; the client side deals with the rendering and the camera controls.

If the server side has too much work to do, you will experience “stutters”. During these stutters, you can still rotate your camera - because it is independent of the game time. If it was coded differently, you might as well be able to move it too.

Your client is independent of that and can still continue rendering and updating (to some extent). That means you can still get 8888 FPS although the server side is technically dead. If you don’t believe me, insert a repeat until false somewhere and see for yourself. The important thing here is that the client does literally nothing except the camera and a few, relatively harmless services. The server deals with the AI, the pathfinding and all the other, nasty things - the sort of stuff that is requiring CPU time like crazy.

To put it in a very bad analogy, you’re asking why a flight got cancelled although the train arrived on time at the airport.

I was never “bent” to say that is a problem exclusively on your side. What I did say however was that it is a well known issue that the developers themselves have reported as they released this version - it’s not a “new” bug nor are you the only one experiencing it.


#18

Hey look I’m a distraction! Let’s all cool with a big fat :smile:

Personally it sounds like some kind of logic panic or race condition that could well be specific to some hardware/software combination. I can’t speculate much since I haven’t been following SH closely nor done much testing or know anything about the over all engine architect. I will shut up and go back to my cave now…


#19

seconded… @untrustedlife, no one is claiming this isn’t worthy of report or discussion … it’s just that this is a known issue, and likely the highest item on their list to resolve (general performance and stability)…

it is, as you said, absolutely worth discussing so Radiant is aware of how pervasive it may be…

deep breaths everyone, we’ll get through this together… :wink:


#20

I’m sorry RP, bit it sounded like you were implying that my laptop wasn’t High end, I should not have brought up FPS again. But there is no question that, Based on the specs I provided in the op . That my gaming laptop IS high end.In fact it is one of the better ones you can get right now. But lets stay on topic.And I am sorry for being so upset ;).

Thanks steve and yes it needs to be discoursed (see what I did there)

(I should have said earler)
The ai is server sided?
I suppose that make sense as they do want to make it fully multiplayer eventually.

The thing I can’t get out of my mind however is that , they also stated that .you could tell it was this bug when your bar was all or a quarter blue. (this isnt the case here… (its just weird (though you DID say that it may not be representative).) so it made me think it was something separate (same result, different action) .which I believe is fully understandable .
But I suppose it is not. so, ok.
(though I did get stutters in the previous version as-well (I get them less now, but yeah))