Misscount between stockpile and crafting UI

Ok, I will try it. Thanks.

And it works!

For now, you can just de-activated that mod when playing with normal kingdoms and activate again when using the little rock guys :slight_smile:

Alpha 22, confirming the issue with Comfy Beds is still here.

Deployed VS. Undeployed. I get the upgrading placed beds thing, but in this case I want them in my inventory, not the world.

Runes Mod, and 2 of mine. Adds the third planter box there and campaign stuff.

1 Like

My potter wouldn’t build the Trading Goods Monument even though I had all necessary items and level requirements.

I managed to deduce the problem - I had four Fine Crates showing as green in the build panel but none were in storage - they had all been deployed. Once one was emptied and returned to storage the Trading Goods Monument was built.

So there appears to be a bug whereby Fine Crates are not being shown as removed from storage when deployed, which results in locking the Monument build tree.

Version Number and Mods in use:
Latest, no mods.

I got a bug report in my mod where the player fisher was not crafting one of his recipes. After some digging in the provided save file, I noticed that the fisher was seeing the required item as available (or stored somewhere) but in reality it was already deployed and placed in the world.

I tested in an empty micro world and it affects (I believe) all crafters.

Here a mason that thinks it has a bed to use in the recipe while it is already placed.

1 Like

I think this is related to what is being discussed in this topic, too.

1 Like

My carpenter is not making the Comfy Bed for some reason. I have all of the materials and I have the toolbench placed, but she only makes other items. I have five items at the top of the crafting queue to be maintained, and items lower in the queue auto-placed from building construction. I have had the mats and everything ready for a few in-game days with the beds queued and she never produced them. I tried changing the bed’s position on the queue to different places as well as trashing the order completely and making a new order for them and she still refuses to make them.

Steps to reproduce:

  1. Have the necessary materials and workbench placed to produce comfy beds
  2. Queue the carpenter to make comfy beds
  3. Be confused as she says nope ima make crates instead

Expected Results:
Comfy beds get crafted

Actual Results:
No comfy beds get crafted

Attachments:

Version Number and Mods in use:
Alpha 21 release-703 x64 no mods

System Information:
Intel® Core™ i7-2600 CPU @ 3.40 GHz 16GB ram Windows 10 64 bit

My guess would be that the mean beds are deployed, and they need to be undeployed.

This is an old ongoing issue with the UI, that sometimes shows only the deployed items or the undeployed ones.

Might be a silly question, but I got to ask: do you have all required ingredients?
E.g., for one of the monuments for The Ascendancy you need a Food Donation Box; the Donation Box is crafted by the Cook and it require Rack of Rost Mutton. And so on.

Personally, I’ve never experienced any issues with any monument.

Yeah i do, i got 10 varanus Skins, etc, i got enough for all of them cuz i wanted to see if there might have been 1 working, but no, it just sits in the waiting list for building and it just says “queued” even if nothing else is there.

That’s very odd - would you mind sharing your save-file?
Perhaps I (and others) can take a look and see what’s going on :slight_smile:

If your account is not able to upload files yet, you could use a service such as dropbox or similar in the meantime ^^

Alrighty sir, think that is correct haha.

I reach Arcadia Bay at Day 7 of Rainmun; it’s a very cute town, I have to say!
I was greeted by happy, well-synchronized Hearthlings. However, I did not pay enough time getting to know them all as much as I wanted to as I was too focused on one in particular - Mard Tenter; the towns’ Mason.
Mr. Tenter showed me his building queue and informed me that he can not find a way to solve it. However, finishing his queue is of utmost important - Arcadia Bay is trying to achive Township, and it’s all down to poor Mr. Tenter to make it happen.

I stayed at Arcadia Bay for 5 days - and, returning from my voyage, I bring news of success!

The Problems

First thing I notice (part from a scaffolding-error) is that there are no Food Donation Boxes and no Heavy Bandage in the town of Arcadia Bay. This explains why the monuments Fountain of Plenty and The Guildmaster’s Skill could not be crafted. (Also, Mr. Tenter was only level 3 on my arrival; level 4 is required for The Guildmaster’s Skill)
However, the third monument, The Valor of Cid, should be craft-able according to the Mr. Tenter’s crafting queue. The fact that he could not begin crafting it had me confused for almost 3 days!

The Solutions

I began by asking Mr. Tenter to craft various simple stone-items at his work station; this would level him up to level 4 while also buying me a few hours to look around town to identify possible problems.

I have organized below my solution that allowed Mr. Tenter to craft each of the monuments.

Fountain of Plenty
  • First, I sat down with Doran Dorril - the Cook of Arcadia Bay; I ordered 10 Sacks of Flour, 4 Poyo Pot Pies, 4 Racks of Rost Mutton, and 6 Peasant Bread. (The other Hearthlings of Arcadia Bay were determined to constantly eat Peasent Breads, Poyo Pies and Rost Mutton, so I ordered a few extra to make sure Mr. Dorril could use a few as ingredients).
  • Secondly, I told Mr. Dorril to craft 2 Food Donation Boxes.

Once Mr. Dorril had crafted the 2 Food Donation Boxes, Mr. Tenter was able to craft the Fountain of Plenty.

The Guildmaster's Skill
  • First, I told Luca Lessel - the only Herbalist found within Arcadia Bay - to craft a bunch of Light Bandages; this was to increase his level to 4 so that he would be able to craft me 1 Heavy Bandage.
  • Next up, I also ordered a bunch of Wall-Mounted Tapestry by Mr. Lessel (it seems to be that some buildings in Arcadia Bay was waiting to use Wall-Mounted Tapestry as decorations - this made it so that Mr. Tenter could not use it as an ingredient!)

Once Mr. Lessel had crafted the Heavy Bandage and the town had at least 1 Wall-Mounted Tapestry in its “not currently used items”-inventory, Mr. Tenter was able to craft The Guildmaster’s Skill.

The Valor of Cid

Looking at the documentation over Arcadia Bay’s Inventory, it claimed there were 9 Goblin Honor Token - only 2 are needed for The Valor of Cid, so Mr. Tenter should have been all set. Should have been.
However, I could only find 1 Goblin Honor Token while going through all the crates, chests, urns, etc!
It seems that the 9 available items that Mr. Tenter was informed about, included placed items as well - so, I asked Abi Brightwell (a local Worker) to undeploy one Goblin Honor Token found in town.

Once Ms. Brightwell had undeployed the Goblin Honor Token, Mr. Tenter was able to craft The Valor of Cid.

Township achived!

Mr. Tenter and I was equally pleased as he - at Day 12 of Rainmun - had been able to craft the 3 monuments.
I couldn’t help myself; I just had to take a picture!

However, at Day 10 of Rainmun, news of Arcadia Bay’s martial prowness had spread.
The town was surprised with a massive invasion at Day 8 of Rainmun; I helped them to fight it of. No Hearthling was killed in the process. I think this epic battle is what caused the words of Arcadia Bays mighty army to echo across the lands.
Thanks to these news, Arcadia Bay qualified as a Township prior to Mr. Tentor completing all of the monuments.
He had finished Fountain of Plenty earlier that day, but Arcadia Bay never applied for Township as we wanted to finish all 3 monuments first.

It was somewhat of a bitter-sweet moment to have Arcadia Bay achive Township prior to Mr. Tentor finishing his crafting queue; however, Mr. Tenter did not seem upset though.

I hope my experiences from Arcadia Bay will help other settlements achive Township in the future.

3 Likes

I don’t know who to ping, so I’ll ping @moderators (thx @Fornjotr!) and hope you’re able to spread to word to the correct person.

The bug reported by @Kimkys is - kind of - occurring due to another “hidden” bug imo.
Some items (such as Goblin Honor Token, Mean Bed, and Wall-Mounted Tapestry) are seen as available ingredients by crafters even if they are deployed.
I know this has been the case for a long time, as I noticed that my Carpenter used to snag deployed Mean Beds when I ordered crafting of Comfy Beds.

However, in the save-file provided by @Kimkys the Wall-Monted Tapestry and Goblin Honor Token required to craft monuments show up as “in inventory” when seen through the Masons crafting-queue - but these ingredients are placed within town (not found within crates etc) and they will not be ahem “borrowed” by the Mason in order to complete the crafting queue.
Instead, we end up in this odd situation where the Mason does not say “I can not find this ingredient” when in fact he can not find the ingredient as it is placed somwehere in town and the Mason will not undeploy it.

  • Did something change regarding “using placed items as ingredients”? (maybe it was a bug in the first place that my Carpenter used placed Mean Beds?!)
  • Is something incorrect with the logic that allows crafters to see what ingredients that are available? (maybe only items within crates, stockpiles, etc should be accounted for - not items that are placed somewhere within town)

Any input from a developer is highly appreciated! :slight_smile:

1 Like

Haha thats strange, I’ve tried doing the Valor Of cid for over a ingame month and got nothing to work, gj sir haha .

Why thank you, @Kimkys!
It all comes down to years upon years of recipe-ingredient searching, crafting-refinement, and, and… no, I’m not fooling anyone with this - it all came down to pure luck to be honest.

Arcadia Bay is a really awesome town imo, thank you for sharing it with me!
I hope you did not mind my attempt at some RP too much; I found myself quite invested in Arcadia Bay, so I wanted to give my respons a touch I typically don’t give any posts. :slight_smile:

2 Likes

Haha it was really cute, i lliked it haha

1 Like

@Hamnisu if you dont know who to ping exactly, use the @moderators tag and you increase the odds :wink:

1 Like

Thanks you, @Fornjotr ! I’ll go ahead and update my previous post according to my new knowledge :slight_smile:

1 Like

Hi!
So i have been sitting here with an mason that wont build any of the monuments required for the quest. It is really annoying to deal with cuz i want to progress.

I tried all solutions i can find, Make a new mason, remove it from Queue etc etc, and nothing works. Tried both Developer Mode and not.
I never used any Mods etc so thats not why, And I dont use commands unless i try to fix something like this.

Anyone got an idea for how i should resolve this?
//Kim

1 Like