Keep getting this when I play my game



I have no more info as I don’t really understand the problem, but I figured I’d post it anyway. If it helps, great! If not don’t worry about it. :smiley:

release-707 (x64)
@stonehearth/components/ai/ai_component.lua:640: (6334863 stonehearth:rabbit) has not yielded after 10 ai spins. Are they in a bad state? Last abort reasons: <follow_path mover aborted reason: could not compute full path in start. (x10)>
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:492: in function 'verify’
stonehearth/components/ai/ai_component.lua:640: in function <stonehearth/components/ai/ai_component.lua:579>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:579: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:273: in function <stonehearth/services/server/threads/thread.lua:270>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:270: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>


Can you send your pc specs please and if there were any other programs running in the background - also, was this a steam or hb version

Edit: were you trying to launch with mods, if yes, which?


No mods, nothing on in the background etc etc…

I found a rabbit stuck inside a mine shaft which was very hungry. Moved an object and it was released. Bug fixed.