Jessespy2's crash (runs game and crashes after 15 secs)

Summary:
when i turn stonehearth on it crashes after 15 secs
Steps to reproduce:

  1. turn stonehearth on
  2. will crash after 15 secs and sometimes starts with no music

Expected Results:

Actual Results:

Notes:

Attachments:


Version Number and Mods in use:
0.22.5 no mods
System Information:

have you tried verifying the files through steam? right click stonehearth>properties>local files>verify integrity

all files successfully validated

Your stonehearth.log may provide some information regarding what caused this issue.
You find this file under …/Steam/steamapps/common/Stonehearth/

2017-10-13 12:51:52.811265 | server | 1 | app | Stonehearth Version 0.22.5.763 (x64)
2017-10-13 12:51:52.813266 | server | 1 | core.config | user id is 606819e4-d3e1-11e6-8969-54271e7a6120
2017-10-13 12:51:52.813266 | server | 1 | core.config | session id is 77980fd6-afc1-11e7-92a0-54271e7a6120
2017-10-13 12:51:52.813266 | server | 0 | core.system | Initializing crash reporter
2017-10-13 12:51:53.321497 | server | 0 | lua.data | lua jit is disabled
2017-10-13 12:51:58.256707 | server | 1 | resources | Modules are verified pristine.
2017-10-13 12:51:58.314744 | server | 1 | app | Running Stonehearth server on port 23410
2017-10-13 12:51:58.331743 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2017-10-13 12:51:58.332744 | client | 1 | game_engine | Initializing OpenGL
2017-10-13 12:51:58.364765 | client | 1 | game_engine | Determining window placement
2017-10-13 12:51:58.364765 | client | 1 | game_engine | Selecting monitor at 750, 468
2017-10-13 12:51:58.365767 | client | 1 | game_engine | Creating OpenGL Window
2017-10-13 12:51:58.398790 | thread9908 | 0 | sysinfo | Memory Stats: Fatal Exception
2017-10-13 12:51:58.398790 | thread9908 | 0 | sysinfo | Total System Memory: 7.941 GB (8526639104 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Current Memory Usage: 43.621 MB (45740032 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Total Address Space: 128.000 TB (140737488224256 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Available Address Space: 128.000 TB (140737162514432 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Used Address Space: 310.621 MB (325709824 bytes)
2017-10-13 12:51:58.684993 | server | 1 | mod radiant | lua controller lifetime tracking set to "nil"
2017-10-13 12:51:58.712013 | server | 0 | mod stonehearth.ai.service | [] enable_cpp_compound_action is on
2017-10-13 12:51:58.742034 | client | 1 | game_engine | Creating OpenGL Context
2017-10-13 12:51:58.743035 | client | 1 | game_engine | Finished OpenGL Initialization
2017-10-13 12:51:58.745036 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘4.5.0 NVIDIA 368.22’ by ‘NVIDIA Corporation’ on 'GeForce GT 620/PCIe/SSE2’
2017-10-13 12:52:00.648437 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:00.858597 | server | 0 | simulation.core | took 106 ms to flush streamer
2017-10-13 12:52:00.911626 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:00.962674 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.013710 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.063761 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.113783 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.163805 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.214853 | server | 1 | network | server allocating new send buffer (total: 0)
2017-10-13 12:52:01.236869 | client | 1 | browser | cef started.
2017-10-13 12:52:01.257882 | client | 1 | browser | Navigate called without an existing browser!
2017-10-13 12:52:01.264874 | server | 1 | simulation.remote_client | started buffering client updates. (seq:10 ack:0)
2017-10-13 12:52:01.472022 | thread6508 | 1 | browser | Doing a buffered navigation…
2017-10-13 12:52:01.735222 | client | 0 | physics.navgrid | subspace pathfinder is enabled
2017-10-13 12:52:01.782261 | client | 1 | mod radiant | lua controller lifetime tracking set to "nil"
2017-10-13 12:52:01.808261 | client | 1 | network | client allocating new send buffer (total: 0)
2017-10-13 12:52:01.854294 | client | 1 | client.core | user feedback is on
2017-10-13 12:52:02.278596 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:10 ack:10)
2017-10-13 12:52:02.329632 | server | 1 | simulation.remote_client | started buffering client updates. (seq:31 ack:10)
2017-10-13 12:52:02.379668 | server | 1 | simulation.remote_client | stopped buffering client updates. (seq:31 ack:31)
2017-10-13 12:52:04.246998 | server | 1 | simulation.core | game loop exhausted before any jobs processed!
2017-10-13 12:52:06.058288 | server | 1 | simulation.core | game loop exhausted before any jobs processed!

sorry but i cant send the .txt yet

I’m sorry, I can’t identify one line that tells the error easy enough for me to understand.
I think you will have to wait for someone with more experience than me to take a look at this :frowning:

In the mean time, I’m guessing that posting your PC specs might assist others who look at this bug report.
Best of luck!

2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Total Address Space: 128.000 TB (140737488224256 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Available Address Space: 128.000 TB (140737162514432 bytes)
2017-10-13 12:51:58.406809 | thread9908 | 0 | sysinfo | Used Address Space: 310.621 MB (325709824 bytes)

could it be this?

2017-10-13 12:51:58.398790 | thread9908 | 0 | sysinfo | Memory Stats: Fatal Exception

this here

This could be it, yes - I fail to see a reason for it though.
When watching my log, I am used to see a short explanation of what’s causing the issue, too.

I think I’ve read in the past that “lua jit” could cause your current issue, however, as your log states

it is disabled and thus should not be the cause :frowning:


Edit: Not sure who to ping in order to get some assistance with this matter, really.
@jomaxro or @sdee, do you mind helping me finding a good candidate? :slight_smile:

(thanks in advance!)

@ayazar this is the one that i talked about in the stream :slight_smile:

2 Likes

What are your computer’s specs?

@jesse_robertson have you tried updating your graphic drivers from here: Download Drivers | NVIDIA ?