Invalid Manifest [SOLVED]

Hello, when I try to active my mod, it says “Invalid Manifest”. Here is my files for Turkish language. Can somebody tell me what’s wrong?
And here is my files: Imgur
{
“info” : {
“name” : “Turkish-Translation-v21.2”,
“required”: true,
“version” : 3
},
“mixintos” : {
“stonehearth/locales/supported_languages.json” : “file(added_languages.json)”
},
“overrides” : {

		"stonehearth/locales/tr-TR.json": "file(translations/tr-TR.json)",
		"stonehearth/locales/tr.json": "file(translations/tr-TR.json)",
		"rayyas_children/locales/tr-TR.json": "file(translations/tr_rayya.json)",
		"rayyas_children/locales/tr.json": "file(translations/tr_rayya.json)",

		"stonehearth/ui/root/css/fonts/autourone/AutourOne-Regular-webfont.eot" : "file(fonts/tr-TR/arcon-rounded-regular-webfont.eot)",
		"stonehearth/ui/root/css/fonts/autourone/AutourOne-Regular-webfont.svg" : "file(fonts/tr-TR/arcon-rounded-regular-webfont.svg)",
		"stonehearth/ui/root/css/fonts/autourone/AutourOne-Regular-webfont.ttf" : "file(fonts/tr-TR/arcon-rounded-regular-webfont.ttf)",
		"stonehearth/ui/root/css/fonts/autourone/AutourOne-Regular-webfont.woff" : "file(fonts/tr-TR/arcon-rounded-regular-webfont.woff)",
		"stonehearth/ui/root/css/fonts/grobold/grobold-webfont.eot" : "file(fonts/tr-TR/Geometry_Soft_Pro-Bold_N-webfont.eot)",
		"stonehearth/ui/root/css/fonts/grobold/grobold-webfont.svg" : "file(fonts/tr-TR/Geometry_Soft_Pro-Bold_N-webfont.svg)",
		"stonehearth/ui/root/css/fonts/grobold/grobold-webfont.ttf" : "file(fonts/tr-TR/Geometry_Soft_Pro-Bold_N-webfont.ttf)",
		"stonehearth/ui/root/css/fonts/grobold/grobold-webfont.woff" : "file(fonts/tr-TR/Geometry_Soft_Pro-Bold_N-webfont.woff)"
   }
}
1 Like

Try changing you mod name to something without capital letter, without the hypen (-), and without dots (.)
Make sure the mod folder has the same name.

1 Like

I’ll try but I did exact same thing with German translation and German works without any problem…

I had problems with it before, so I always use that style.
Is your mod just a folder or a *.smod file?
If it is a folder, make sure the manifest is right inside it, and not inside other folders in it.
If it is a *.smod, make sure you created it compacting the mod folder into a .zip and renaming the extension to .smod

It’s like this.

That is right. When you compacted the folder using winrar, did you chose the option to compact into zip? Else it compacts into rar, and that even after renaming will not work. You need to compact direct into zip.
Like this:

1 Like

I don’t remember which one I did. What you said at your first comment was right! I removed hypen (-) and dot (.) and it’s working now :smiley: Thank you so much.

1 Like