I found a ton of stonehearth building bugs. How do i fix this?

So this worker is stuck inside my building’s wall and he can’t get out for some reason LOL.
I finally made this house with 2 floors and then this guy got stuck Q.Q . How do I get him unstuck?

I build this house with 3 floors and everything is perfect except that I can’t place furniture on the first floor(there are ghost dining tables but the wont get filled) and the villagers wont remove the stairs+scaffoldings. What do I need to do so the can remove it?

And for the 3th amazing bug of today… I made a 3th house but there is this hole inside the wall and the wont fill it for some reason. How do I fix this as well?

1 Like

Hello @mariotusek, welcome to the forum.

For the first one, try building a ladder on the walls so the hearthling can descend to the floor.

The second one might be a case of hearthlings not wanting to enter the building, but I’m not sure. Is the scaffolding completely removed? There are many ladders on that picture…

The 3rd image I think either you don’t have enough materials, or the lantern and the flowerbox are preventing the scaffolding to be built, so the hearthlings can’t access the upper part of the wall to finish it. I’m not sure that they would finish the wall even if you undeployed both items, but could be worth a try… :disappointed_relieved:

1 Like

remove all outside decorations, because they are in the way.
the scaffolding must be completed before construction will go on and flowerboxes, lanterns etc are spaces where scaffolding needs to be build, but couldnt.
you can of cause keep the decoration if you build a ton of ladders directly at the wall, so workers can reach the places where blocks need to be built. thats a lot of work though.

for the issue with ghost furniture… save + reloading the game solves it for me, could be worth a try. also make sure you have the right stuff in your storage (not someones backpack or fine/notsofine versions)

1 Like

The second issue could be a case of “blueprint absorption”, if you tried placing them while the house was being built. If a building’s under construction, the items are placed into the “design” of the structure, rather than just being placed as an object. There’s all sorts of issues still that result from this (at least in my experience), so what I tend to do is wait for the construction to completely finish (there can still be scaffolding, but make sure they’re tearing it completely down and that there’s nothing left to be built). Other potential issues could be stockpile numbers or location of objects–where are the other tables, in stockpiles or crates?

There third issue, like @Relyss mentioned, is the objects in the way of the wall. Remove the lamp and flower box, and the scaffolding should be finished and the wall constructed.

Ty ^^ the first one worked but the second one did not… the do enter the building because I see them sleeping inside the building every time and the even go to the roof to stash the gold in the chest.

The 3rd problem was the flowerbox that prevented them from removing the scaffolding :confused:

now I only need to find a way to fix this problem. For some reason i can remove the ladders I place but I cannot remove the ladders the villagers put to make the building.

I removed everything from the second building with the sacffoldings and ladders, the building is finished but the do not want to remove the scaffolding+ ladders :cry:

a workaround for this is using the console,

  • select the object you want gone (the scaffolding)
  • open up the console (left Ctrl + C)
  • type destroy and hit enter
  • close the console the same way you opened it

that should work.

A post was merged into an existing topic: The buildings my hearthling will not build Thread