Game kicks me to desktop but keeps running

Now and then, the game kicks me to the desktop, but keeps running with mixed results

Steps to reproduce:

  1. Playing the game - thought it might be a particular action causing it, but tried to take notice what I was doing when it kicked and what it might be doing and it seems to be a range: marqueeing a new mining area, watching hearthlings fill a new trunk, clicking on the notices button, inspecting a goblin, marqueeing loot for collection, watching them bustle around, trying to change slices, designing a building, watching a building get built, game on pause reading a description… More…

  2. The screen suddenly flashes to desktop. No error message, no alerts, no other programs pulling focus. In game music continues, sound effects continue if it hasn’t crashed.

  3. Most times it hasn’t crashed an I can click on the icon to return to the game.

  4. Rarely I can continue to play. Often the game continues and I can highlight objects and change the camera but can’t interact with anything, no UI buttons work, no characters can be selected, objects can be selected but don’t show info panel at lower left, no crafting panels open, no building, no terrain view buttons, pause or play buttons. Keyboard doesn’t work: ESC doesn’t work. It won’t pause/unpause with 1, 2, and 3 keys. No shortcuts work. Can’t save. I can use option+tab to get out back to desktop tho.

  5. Can only really force quit. Luckily use autosave so never lose much progress, but still annoying.
    Had tried tabbing to desktop and back to the game but no dice - game still doesn’t work.

Expected Results:
It doesn’t seemingly completely randomly kick me

Actual Results:
completely randomly kicks me

Once there was a dialogue box that flashed up after it kicked me but it is so quick there was no chance of seeing what it said. Or recognising it as either a system dialogue or a game one - I did see an orange colour so I would guess a game one.


Version Number and Mods in use:
726 x32
Only the a…'s children mod that comes with the game (forgot name)

System Information:
Windows 7

Sorry you’re having the issue!

I personally can’t find anything that can cause such problems, so i’ll page the @moderators , but for now, could you detail your system information? I think it might be the biggest culprit, probably RAM, graphics card, and CPU/core


Hi @Darren_Ballingall. Thanks for submitting this bug report.

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

The next time this problem occurs, if you could also provide your stonehearth.log file. This is located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth – Because this log gets recreated every time you start Stonehearth, it’s important that you submit this file before starting the game again. This ensures it will include that session’s log entries.

Please let us know if you have any questions or problems finding or submitting these files.

1 Like

This occurs for me with several games.

It is possible that this is not due to Stonehearth, but rather Anti-Virus software performing tasks in the backend or similar software that has a popup occur “randomly” whilst things are checked.

My suggestion would be to google the symptoms.