Game crashing without any specific action occuring

Summary:

  1. Game starts to lag (not an fps drop, just lag)
  • The bottom bar resource manager thingy says Lua uses 70% of the total resources.
  1. I try to quit, screen goes black (music also stops).
  • Stay like that for ~30s
  1. Mouse teleports itself to the center of the screen.

  2. After ~2 minutes the black screen changes into my lock screen

  3. I log in to my windows user, every program open has been closed.

  4. I try to re-open Stonehearth

  5. It says:

8, I restart my PC

9, Stoneheart opens just fine

10, I continue my game

[Jump to step number 1 and repeat]

I did this 2 times. After the second time I decided to make bug report

Attachments & Stonehearth.log:

Link to logs

Versions and Mods:

The newest version. “Stonehearth Version 0.17.0.610 (x64)

System Information:

Windows 10, GTX750 2GB Gpu, 8GB Ram, i5 4460 Cpu

Have you attempted basic troubleshooting steps here: http://discourse.stonehearth.net/t/crashing-on-start-read-this-updated-october-28/13297:

Yes I tried, they didn’t work.
Gpu is already updated & administrator mode didn’t seem to work.

Notes:

ATTENTION: My Stonehearth has been working fine for many days. So that limits out many possibilities, does it not ? And before the first symptoms I managed to play 4 hours of Stonehearth.

Ask if you need more information, that I can provide.

Hey there @AnotherDoor, so sorry for the delay in getting you a response here - we try and deal with crashing issues right after they’re reported.

I’ve never seen that dialog before, so I’m going to ping @Albert and @not_owen_wilson as I’m assuming one of them added that to the game.

Looking at your logs and crash dump, I’ve noticed a few things. First, the game in not seeing your NVIDIA graphics card. The log is reporting Display device 0: Microsoft Basic Display Driver, and not logging a driver version as it typically does. Second, I noticed that an application called “overwolf” is being loaded into the game. Was that something you installed at a similar time to when the issue first occurred?

Finally, while we wait for the devs, if you could upload your logs before step 6 (re-launching Stonehearth), I’d like to take a look at them. The logs are overwritten at launch, so the logs you shared appear to be from after you attempt to launch Stonehearth when it displays the message about OpenGL.

Thanks!

Thanks for helping me out :stuck_out_tongue:
Also it seems the laggy part goes away if you wait enough. And about overwolf, it doesn’t matter if it’s on or off. But for the name of science I try to crash my stonehearth and paste you the logs.

1 Like

Thanks! Hopefully we can find something in the logs from the came crash (as opposed to the game failing to launch) that will point us in the right direction.

Okay, so I played 1h and got one lag spike. When the spike came, I tried to crash the game intentionally by quiting to main menu. But I noticed it only perma freezes the game. I should have used: “quited” :confused: Now it doesn’t want to create another Lua lagspike. So I’ll try again tomorrow. I can still suply you the logs. I don’t know if the perma freeze (I waited 5min) will show up in the logs. (After the five minutes I closed my stonehearth (alt + f4))

Link

Edit: Done’d @jomaxro

The link doesn’t seem to work for me, could you double check it? It directs me to the MediaFire homepage.

1 Like

Thanks for fixing that link! I found this in the logs:

std::logic_error: 'invalid reference in native get_id'
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback'
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'get_id'
radiant/modules/entities.lua:274: in function 'get_world_location'
radiant/modules/entities.lua:74: in function 'exists_in_world'
stonehearth/components/ai/ai_component.lua:515: in function <stonehearth/components/ai/ai_component.lua:509>
[C]: in function 'xpcall'
radiant/modules/common.lua:257: in function 'xpcall'
stonehearth/components/ai/ai_component.lua:509: in function '_thread_main'
stonehearth/services/server/threads/thread.lua:249: in function <stonehearth/services/server/threads/thread.lua:246>
[C]: in function 'xpcall'
radiant/modules/common.lua:257: in function 'xpcall'
stonehearth/services/server/threads/thread.lua:246: in function 'f'
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

Hopefully one of the devs can help interpret this.

That’s a pretty nasty error. It looks like the game is trying to run a hearthling ai after it’s been destroyed.

Can you post the save game that generates the lag spikes?

Just in case you’re unsure how:

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

@Albert @jomaxro

Oh sorry, my mail notifications have not been working properly and only now I saw your replies.
Yes, I will send the savegame data when I get home, and how many of them you need? I have +100 backups starting earlier than when the first dude died (poor worker). Either way I will send the newest, and few from between.

1 Like

Sounds good. I’m sure Albert will ask you for a specific one if the few you share don’t give him what he needs.

@Albert

Okay here are 4 I found. 2 of them are named and they are quite recent, and the 2 others which contain “no idea” title are somewhat old, and the eldest of them may be before the villager died so you can skip it. Here, should work

1 Like