Game crashes without error message

Since I bought this game yesterday it has been crashing roughly every 5 minutes without an error message. The problem seems very similar to the crashes people are getting on AMD cards, but i’m using an NVIDIA GeForce GTX 870M on Windows 8.1 64-bit. All my drivers are up to date (I updated them before launching the game) and I’ve tried some suggested fixes from this forum, but nothing so far has worked.

1 Like

hmm… what’s the processor on your laptop?

@SteveAdamo Intel Core i7-4710MQ CPU @ 2.50GHz

There’s nothing in the stonehearth.log?

Perhaps devs can see if the crash was recorded by the crash reporter…

Here’s the log, there seems to be some sort problem with some ‘qubicle file’

stonehearth.log (12.7 KB)

Anyone gonna help or is this just not fixable at the moment?

Hi, I’m having the same problem.

My PC specs:
Intel i7 3770
AMD Radeo HD 7850 2GB (latest drivers)
Windows 7 64bits

This is the extract from the .log file:
2014-Dec-18 11:01:39.462796logger initialized
2014-Dec-18 11:01:39.462796 | server | 1 | app | Stonehearth Version
2014-Dec-18 11:01:40.183798 | server | 0 | | lua git is enabled
2014-Dec-18 11:01:40.703401 | server | 1 | resources | Modules are verified prestine.
2014-Dec-18 11:01:40.719001 | server | 1 | app | Running Stonehearth server on port 18119
2014-Dec-18 11:01:40.765801 | server | 0 | mod stonehearth.world_generation | initialize not implemented for world generation service!
2014-Dec-18 11:01:40.765801 | server | 0 | mod stonehearth | greedy task scheduling enabled
2014-Dec-18 11:01:41.141003 Fatal Exception.
2014-Dec-18 11:01:41.141003 Total System Memory: 9.948 GB (10682105856 bytes)
2014-Dec-18 11:01:41.141003 Current Memory Usage: 80.934 MB (84865024 bytes)
2014-Dec-18 11:01:41.141003 Total Address Space: 2.000 GB (2147352576 bytes)
2014-Dec-18 11:01:41.141003 Available Address Space: 1.747 GB (1875308544 bytes)
2014-Dec-18 11:01:41.141003 Used Address Space: 259.441 MB (272044032 bytes)

just out of curiosity, do you have any mods loaded?

are you seeing this same error in your logs?

2014-Dec-17 15:14:38.469021 | client | 1 | renderer.renderer | invalid visible region reference: object://game/364383
2014-Dec-17 15:14:38.469021 | client | 1 | renderer.renderer | invalid explored region reference: object://game/364384
2014-Dec-17 15:14:38.515054 | server | 2 | network | server allocating new send buffer (total: 0)
2014-Dec-17 15:14:44.502303 | client | 1 | renderer.render_info | could not load qubicle file: invalid file path ‘’.

@SteveAdamo I don’t have any mods loaded

Also I had to manually override the game’s graphics settings in the NVIDIA Control Panel so that the game would select my NVIDIA card as opposed to the Intel one (the game was unplayable due to lag with the Intel one), just incase that helps

1 Like

I think a lot of people are having this issue, please can we get some help?

@185000a - Any chance of a log (as @clodan posted)? May help.

In the mean time… hmm. A clean reinstall not helped (note: Steam DOES NOT wipe all the files if you uninstall a game via it - go into the Steam folder and check manually that Stonehearth is gone)…?

Also paging @sdee & @not_owen_wilson I guess, see if they can shed any light on it.

1 Like

If it’s crashing on loading a qb file, could you check to make sure that you have no mods installed, not even candledark? Mods are not uninstalled on reinstall from steam, so you have to nuke the whole stonehearth folder and reinstall from scratch.

1 Like

Sorry, was out and couldnt log in before. I dont see any messages like Steve posted. It just closes without any kind of messages. Are there any requirements for the game? Like the C++ libraries or a specific version of Dx?

That WAS my log that was posted, not clodan’s. Also i have no mods loaded. Tried reinstalling and doesn’t help.

Sorry - browsing quickly & didn’t see the link :stuck_out_tongue: .

Anyway, yeah the lines like this are what @Sdee is going on about:

Sounds like either a mod or a corrupted file. I suggest nuking the SH folder & doing a clean installation, and seeing if that helps any.


Not a mod because I play vanilla and the invalid file path ’ ’ errors appear in my logs when I’m experiencing the failed saves and crashing to desktop issues.

Hm, the issue seems more complicated than we can diagnose here. If you’ve opted into our crash dump service, please send us your user id (from the settings panel) via a post to this thread or a PM, and we’ll see what we can find in the detailed crash dump service. Thanks!

1 Like

As recommended, i will try to do a complete clean installation.

As far as I know the only folder to be completely erased is the steam/common/stonehearth right?

1 Like

Yup, steam/common/stonehearth!