Game crashes Immediately upon startup (Lavasoft Ad-Aware)

First off, love the game. Just bought it and played it for 4 hours straight on my tower pc. But I recently installed it on my laptop and it crashes within a few seconds of launching. I tried running it in compatibility mode for both windows 8 and 7, uninstalling and reinstalling it, and running it as administrator. So far nothing seems to work. Any help would be awesome :grinning:

PC specs
Processor Intel Core 17-4720HQ CPU @ 2.60GHz
RAM: 12 GB
Windows 8.1
GPU: Geforce GTX 950m

Also I cant upload attachments since i’m new so here is a copy paste of the stonehearth log file… Sorry!

2015-Oct-26 19:58:49.157010 | server | 1 | app | Stonehearth Version 0.12.0.460 (x64)
2015-Oct-26 19:58:49.157010 | server | 1 | core.config | user id is 06d8aae8-7c34-11e5-b44a-40e230d77d58
2015-Oct-26 19:58:49.157010 | server | 1 | core.config | session id is 8045b7b6-7c3d-11e5-89e3-40e230d77d58
2015-Oct-26 19:58:49.157010 | server | 0 | core.system | Initializing crash reporter
2015-Oct-26 19:58:49.672676 | server | 0 | lua.data | lua jit is disabled
2015-Oct-26 19:58:50.892660 | server | 1 | resources | Modules are verified pristine.
2015-Oct-26 19:58:51.048909 | server | 1 | app | Running Stonehearth server on port 16631
2015-Oct-26 19:58:51.128332 | client | 1 | renderer.renderer | Initializing OpenGL
2015-Oct-26 19:58:51.128332 | client | 1 | renderer.renderer | Determining window placement
2015-Oct-26 19:58:51.128332 | client | 1 | renderer.renderer | Selecting monitor at 0, 0
2015-Oct-26 19:58:51.128332 | client | 1 | renderer.renderer | Creating OpenGL Window
2015-Oct-26 19:58:51.159581 | server | 0 | mod stonehearth | greedy task scheduling enabled
2015-Oct-26 19:58:51.848895 | client | 1 | renderer.renderer | Creating OpenGL Context
2015-Oct-26 19:58:51.848895 | client | 1 | renderer.renderer | Finished OpenGL Initialization
2015-Oct-26 19:58:51.864521 | client | 1 | horde.general | Initializing GL2 backend using OpenGL driver ‘4.5.0 NVIDIA 358.50’ by ‘NVIDIA Corporation’ on 'GeForce GTX 950M/PCIe/SSE2’
2015-Oct-26 19:58:52.505153 | client | 1 | browser | cef started.
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Memory Stats: Fatal Exception
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Total System Memory: 11.892 GB (12768546816 bytes)
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Current Memory Usage: 183.398 MB (192307200 bytes)
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Total Address Space: 128.000 TB (140737488224256 bytes)
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Available Address Space: 127.999 TB (140736440766464 bytes)
2015-Oct-26 19:58:52.536417 | thread2748 | 0 | sysinfo | Used Address Space: 998.934 MB (1047457792 bytes)
2015-Oct-26 19:58:52.677029 | client | 2 | network | client allocating new send buffer (total: 0)
2015-Oct-26 19:58:52.958299 | client | 1 | client.core | user feedback is off

hey there @Seal, welcome to the discourse :smile:

thought i’m not much help here, i’ll page @Albert for you, he should be able to figure out whats causing this crash. also, have you taken a look at this thread?

I had not though its similar to the one I found on steam that lead me here. I seem to have tried everything in that thread except for turning off full screen mode. But the game already launches in windowed mode for 3 seconds before it crashes so I don’t think that will help. I also updated my drivers to no avail.

1 Like

hmm… whats in your user_settings.json?

Im assuming I open it with notepad.

{
“user_id” : “06d8aae8-7c34-11e5-b44a-40e230d77d58”,
“mods” : {
“stonehearth” : {
“enable_cpp_ai” : true
}
},
“simulation” : {
“use_subspace_pathfinder” : true
},
“config_id” : 1
}

[quote=“Seal, post:5, topic:17382”]
Im assuming I open it with notepad.
[/quote]yep, that works perfectly fine!

hmm… that doesnt look right, try pasting this into instead,

{
"user_id" : "06d8aae8-7c34-11e5-b44a-40e230d77d58",
"collect_analytics" : true,
"enable_auto_save" : false,
"renderer" : {
    "run_once" : true,
    "use_high_quality" : false,
    "enable_ssao" : false,
    "enable_shadows" : false,
    "shadow_resolution" : 256,
    "msaa_samples" : 0,
    "shadow_quality" : 1,
    "max_lights" : 30,
    "enable_vsync" : false,
    "enable_fullscreen" : false,
    "screen_width" : 1920,
    "screen_height" : 1018,
    "draw_distance" : 1000
},
"audio" : {
    "bgm_volume" : 0.6,
    "efx_volume" : 0.6
},
"enable_lua_jit" : false,
"force_32_bit" : true,
"language" : "en"
}

its not a guaranteed fix, but it has worked in the past.

1 Like

You sir, are the best. That worked and it seems the game is running fine now. Thank you for all your help!

1 Like

nah… second best… maybe. :wink:

[quote=“Seal, post:7, topic:17382”]
That worked and it seems the game is running fine now.
[/quote]awesome!

[quote=“Seal, post:7, topic:17382”]
Thank you for all your help!
[/quote]no problemo, thats why i’m here.

2 Likes

The legendary crab :smiley:

1 Like

@seal - The crash report says that Lavasoft Ad-Aware is causing stonehearth to crash in 64-bit mode. If you intend to build larger towns, you will need to disable / uninstall Lavasoft so that you can run stonehearth in 64-bit.

2 Likes