Game automatically paused and cannot resume!

Hi, the game automatically paused itself (I believe :S ) and I tried to resume the game by going to the menu and press Resume but nothing happened and am stuck in pause mode !!!

numbers 1-4 can pause and change the game speed
1= pause
2= normal
3=2 times normal
4= 3 times normal ( only if you check the box in the settings)

EDIT: you can also click on the ‘=’, “>” and the “>>” buttons at the bottom right of your screen

Hi. The problem is not pausing or resuming the game. The problem is the pause once enabled gets stuck there and no matter what method or hot key I try to resume it, it simply doesn’t work to resume game.

Hello @tay_thotheolh :smile:

Which Stonehearth version are you playing?
Do you have autosave enabled?
How many hearthlings do you have in that game?

Is the Paused message stuck in the screen? You should be able to resume with the “>” button… Have you tried saving / restarting Stonehearth?

1 Like

I am using version 0.12.0 Alpha release 472 x64 build. I can’t seem to reproduce the same problem in other new games though. I could access the menu and quit the game into a new game.

Hey there @tay_thotheolh. seeing as you could access the menu, did you try saving the game, quitting, and then reloading the save?

No I did not save or reload it. It was already irritating enough to have a resume not working so might as well enter a new game.

Alright. Seeing as you are unable to replicate the issue, and do not have any logs or save games for the devs to analyze, I am going to move this to Other Reports for now…and am going to page @Albert just in case he can think of something that I can’t. If you get this bug again, please post again and I will pull the thread right back into bug reports.

Hi, I have somewhat managed to replicate the Pause bug but in a different occassion. I was saving a game and now it cannot resume anymore. I reload the saved game and after the game reloaded, it immediately enter into pause mode and refuse to resume.

Inside the saved_game I uploaded, I have managed to lay down potted plants in the water as well with a “Hi” message to the Devs “written” using the potted plants (if they manage to resume it and watch :)). I believe planting or laying down buildings and furnitures in the pool of water is a bug as well.

I also noticed that when I attempted to surround a small piece of land with cobblestone walls and a stone gate, it somehow makes the game noticeably more laggy and the lag continues until bugs and crashes (like the Resume problem) occurs and finally crashes the game.

This uploaded saved_game contains a lot of errors which hopefully can be used to do multiple debugging all in a single session.

Here is the link: - Google Drive

1 Like

Definitely strange save @tay_thotheolh…I had no issue clicking play and resuming the game. I even starting the house you had there:

Regardless, I am sure the devs would love to see the save.