Freezing every 10 seconds

Hello! I’m running Stonehearth alpha 24, and the problem I have is the game freezes every 10-15 seconds, for around 5 seconds.

I uninstalled the game, and reinstalled (through Steam) - the issue remains unfortunately.

My specs:
intel i7-4790k
GTX 1080ti

Is there anything obvious I could try troubleshooting here? Many thanks for your time.

lol mine freeze whenever i open every job craft menu

1 Like

If it helps anyone else, I looked at the compatibility settings of the .exe in the Steam folder and noticed the game was set to run under Windows 7. After un-checking this option, the game runs without freezing now.

that’s too general in saying how to fix.

need step by step thanks in advance.

p.s. I use window 10, but after checking compability, i only see max at windows 8.

p.s.s whoops forgot to read to uncheck

p.s.s.s tried, still laggy

Sorry you’ve still got freeze problems. One thing you could try is to exclude the Stonehearth folder in your antivirus software. In Avast, this is under settings > exclusions.

You might also want to try forcing 32-bit in the game via settings > system.

p.s. multiple postscripts use the format ‘p.p.s’, not ‘p.s.s’.

p.p.s e.g. this is a post-postscript

p.p.p.s this is a post-post-postscript etc.

Judging by the spec of your rig, I think I know the answer…

@Lylio Are you running the game from an SSD? Just a question to see if anyone else has had the same issue as me.

btw the compability can change depending if the devs makes it so it can be compatible with anything or is it from the computer side?

i’ve had many crashes even after the that.

already done force 32-bits too.

Yeah Froggy, I’m running from an SSD.

Hmm. My system is a similar spec to yours. When I run SH on my SSD I get the same issue. 10 seconds of play followed by 5-10 second lag. The log is filled with 5580ms to respond etc. Moving the installation to my storage HDD made the game run smoothly. Thought it was just me but SH might be allergic to SSDs? O.o I also have much longer save loads on the SSD compared to the mechanical drive. Will be interesting to see if anyone else has this issue…


@Froggy Any chance you were using a virtual folder or had it mapped to a drive letter?

Hey Albert. Standard steam installation / drive mapping, can’t seem to reproduce in this version. I’ll let you know if it comes back

1 Like