Found a strange crash issue with constructing a wall & door in a mountain face

I found a strange crash issue by doing the following:
I cut some stairs into a mountain side.
Then I built a road in the stairs and completed their construction.
Next I built a wall across the road from one side to the other, and attempted to place two doors into this wall.
The first door was placed fine, the second door would not place and instead popped an error (which I closed without copying, I’m sorry). I then tried placing the door a couple more times, but it would not display.
This is when I noticed some pretty extreme slowdown, so I decided to save just in case - the file saved, and then I tried to do some other things to fix the wall (I’m sorry I don’t remember what). And then the game crashed, as well as did my computer.

Steps to reproduce:
Unsure - tried to explain it best I could above.

Expected Results:
Should be able to build walls and doors wherever I want.

Actual Results:
It seems that building this particular door crashed the game.

I added my file - I guess I saved at the perfect time. Loading this file takes forever and I think is recreating whatever issue crashed my computer - as soon as I noticed the slowdown again I force quit the program and wrote up this bug report.


Version Number and Mods in use:
Latest Steam Alpha.
Mods: Archipelago Biome, LocksOfColour, Patrol Mod, Terrain Colors, Tuhalu

System Information:
Intel Core i7 950 @3.07 GHz
NVidia GeForce GTX 760

That’s weird. You’re already user level 2, you should be able to upload attachments. Perhaps the file was too big?
You can try uploading it to a free hosting site (like Dropbox, Google Drive, etc) and sharing the download link here.

Can you try uploading an image of your construction? That should be small enough to test if you can really upload attachments.

I’ll try a hosting site when I get home. I dont think its a permission issue - it tried to load it, but would get to about 35% and then start over. No errors or anything, it was strange.

it look like your file is too big for the post size limit

It is over 50 mbs, so I guess that is a little large. Here is a link to the save file: - Google Drive