"Failed to launch game, invalid platform"

Since Alpha 20 the game refuses to launch because it is an “invalid platform.”

Windows 7 pro SP1 (64x)
ADM FX™-8320 Eight-Core processor 3.50GHz
NVIDIA GeForce GTX 750
8GB Ram

When attempting to launch from steam I receive an error:
Failed to start game (invalid platform).

When attempting to launch from the file or start menu:
The version of this file is not compatible with tthe version of Windows you’re running. Check your computer’s system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

Things I have tried:

Pretty much everything in your “Crashing on Start?” thread and “HELP! I can’t play the game!” thread including …

Disabling Ublock Origin
Disabling Avast Antivirus (which was giving me false warnings about the crash_reporter.exe)
Modifying my user_settings file to enable 64 bit
Completely uninstalling and reinstalling Stonehearth including the deletion of the stonehearth file in my steam/userapps (I use no mods)

I thought I would be okay with out my poyo hugging fix for a little while but… well… I’m getting kind of twitchy. :sweat:

Any and all help would be greatly appreciated.


hey there

got the same problem since a20 and tbh im kinda sad that theres no reply after 3 days in a recommanded forum!

hey there @Anotherneko and @Diego_Cosme,

this is most likely due to the fact the game no longer supports Vista, so it could be stopping Windows 7 versions from running the game as well for some reason… :confounded: i’m not even sure who to page for this… guess i’ll page @sdee so she can get the right people looking into it

1 Like

@Diego_Cosme, welcome to the Discourse. Just to confirm, you are running Windows 7 as well?

1 Like

I run on Windows 7 and am not having those problems. Just so you know.


@Diego_Cosme, @Anotherneko, can you please provide a copy of your msinfo32 details so we can try and hunt this down.

Launch System Information:

  1. Start > Run (or win+R)
  2. Type “msinfo32”
  3. Click File :arrow_right: Export
  4. Enter a name, and upload the txt file to the Discourse.
1 Like

I think the problem is with steam because i have the same problem but can run the game from the .exe perfectly.

here u go


would like to upload the file directly but
"new users can not upload attachments."
so i have to do it that way. its just the german file
cause somehow i cant dl the english language pack.
if u need the english one i need to find a way
to get the eng pack.

thx for the help

just so u know i can start the game from the .exe too
but thats only a temporary solution and does not fix the problem.
the problem seems to be something between steam and the game
but im not into the programming materia so its just a guess of me.

Thanks for the confirmation @Diego_Cosme, and thanks for the suggestion @luquitacx. All good information for the team to investigate with. You’re on the absolute latest version of Windows 7, so you should be able to play without issue.

msinfoAN.txt (1.8 MB)

Hello, sorry for the long delay, the poyo withdrawl was … well… you can imagine. Twitch twitch

Thank you for looking into this!

1 Like

A post was split to a new topic: Cannot launch the game