Error while creating new building

unsure what exactly caused this, or even if its possible to reproduce it. was just creating a building from scratch. created a foundation, added walls, then two doors, windows, then clicked roof. after clicking offset to -1. then raising it to 2 or 3, then lowered it back to 0 and then got this message;

(page 1)
release-537 (x64)…onehearth/components/building/building_component.lua:288: attempt to index local ‘entity’ (a nil value)stack traceback:
[C]: ?
…onehearth/components/building/building_component.lua:288: in function 'get_building_envelope’
stonehearth/components/roof/roof_component.lua:222: in function 'clip_overlapping_structures’
stonehearth/components/roof/roof_component.lua:76: in function ‘layout’
…onehearth/components/building/building_component.lua:211: in function 'add_structure’
stonehearth/lib/build_util.lua:1048: in function 'bind_fabricator_to_blueprint’
stonehearth/services/server/build/build_service.lua:420: in function 'add_fabricator’
stonehearth/services/server/build/build_service.lua:472: in function '_create_blueprint’
stonehearth/services/server/build/build_service.lua:1070: in function 'grow_roof’
stonehearth/services/server/build/build_service.lua:1036: in function 'cb’
stonehearth/services/server/build/build_service.lua:1450: in function 'do_command’
stonehearth/services/server/build/build_service.lua:1035: in function <stonehearth/services/server/build/build_service.lua:1033>
(page 2)
release-537 (x64)c++ exception: lua runtime errorstack traceback:
Expected Results:

Actual Results:



**Version Number and Mods in use:latest (just downloaded on new gaming laptop) no mods

**System Information:Gigabyte P15F V5-CF1 8 gig ram intel onboard gpu + nvidia gtx 950M 2GB GDDR5 Processor Intel Core i7-6700HQ CPU 2.60GHz windows 10 home 64bit

1 Like

It seems like i’m unable to remove building too. remove doesn’t do anything

1 Like

loaded an earlier save before i started building, tried to place the building as i managed to save it and unable to. get this error:

(page 1)
release-537 (x64)…onehearth/components/building/building_component.lua:654: assertion failed!stack traceback:
[C]: ?
[C]: in function ‘assert’
…onehearth/components/building/building_component.lua:654: in function 'load_from_template’
stonehearth/lib/build_util.lua:126: in function 'load_structure_from_template’
stonehearth/lib/build_util.lua:134: in function 'load_all_structures_from_template’
stonehearth/lib/build_util.lua:433: in function ‘restore_template’
…rth/services/client/build_editor/template_editor.lua:25: in function ‘restore_template’
…rth/services/client/build_editor/template_editor.lua:76: in function ‘go’
…ervices/client/build_editor/build_editor_service.lua:251: in function <…ervices/client/build_editor/build_editor_service.lua:249>

(page 2)
release-537 (x64)c++ exception: lua runtime errorstack traceback:

1 Like

Were you able to save a template? That or the save file might help the team with fixing this.

I was able to save it, but when i tried to place it after reloading i just got the error above. and unfortunately, i’ve overwritten the template

A post was merged into an existing topic: Weird glowing shifting wall bug

I’m having the same issue. I can’t build anything at all after receiving the following error:

develop-3023 (x64)…onehearth/components/building/building_component.lua:386: attempt to index local ‘entity’ (a nil value)stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
…onehearth/components/building/building_component.lua:386: in function ‘_trace_entity’
…onehearth/components/building/building_component.lua:145: in function ‘_restore_structure_traces’
…onehearth/components/building/building_component.lua:94: in function 'obj’
radiant/modules/events.lua:73: in function 'instance’
radiant/modules/events.lua:206: in function <radiant/modules/events.lua:200>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:200: in function <radiant/modules/events.lua:171>

Now the custom building is stuck and can’t be deleted and I can longer build anything else.

Using latest build 3023.