Error reading manifest - adding trappable critter

Hello there,
i`m trieing to at a snowhare, which is trappable and the pelt is sellable.
So i created a new .qb, did all the stuff to have a working snowhare
Everything was quite easy (copy and paste things from the rabbit) BUT
it seems that my manifest had a problem so i checked it with Jofferson 1.5.3 and after some errors and changes it passed without errors.

But now when i start the game the log file looks like this:
2015-Jun-18 15:20:37.785399 | server | 1 | resources | Error reading manifest of snowharemod: Missing :
(followed by the manifest)
Can someone please explain to me whats wrong with my manifest ?

Copy your manifest here so we can debug it. Failing that paste it in to jsonlint and it should tell you where you’re missing the :


Pretty much what I was going to say. Was just looking at Jofferson and it hasn’t been updated in 10 months. That seems super out of date for a game that’s had several major versions since then, so it’s results aren’t necessarily correct (for instance, it reckons the latest versions of radiant and stonehearth mods are faulty).

Here it is.
I copied it into jsonlint and found the error it was the comma in line 14
I deletetd it and now game crashes …lol

“info”: {
“name”: “snowharemod”,
“version”: 1
“aliases”: {
“snowhare”: “file(entities/critters/snowhare)”,
“snowhare_jerky”: “file(entities/critters/snowhare/snowhare_jerky)”,
“resources:snowhare_pelt”: “file(entities/resources/pelt/snowhare_pelt)”
“mixintos”: {
“stonehearth/entities/critters/rabbit/rabbit.json” : “file(entities/critters/snowhare/snowhare.json)”,
“stonehearth/mixins/food/jerky/jerky.json” : “file(entities/critters/snowhare/snowhare_jerky/snowhare_jerky.json)”,
“stonehearth/entities/resources/pelt/rabbit_pelt/rabbit_pelt.json” : “file(entities/resources/pelt/snowhare_pelt/snowhare_pelt.json)”


Hmm, you cant use mixintos that way. I think you are trying to override, rather than mixin.

hmmm…might be. but i dont want to override the rabbit into a snowhare. I want to add a new critter for the traps.
I read (correct me if im wrong) that theres no way of adding new folders by mixin. So i thought of adding my jsons into existing ones.

I´m just beginning modding and this is my first project, so please explain detailed if possible.

You’ll have to create a new static scenario. Copy the rabbit_nest and remove your mixins from the manifest.

You’ll also have to mixinto scenario_index.json

1 Like

ok a little work but i did that…testing is on
corrected some things after checking in jsonlint
rewritten the manifest

But i thought critter nest are just for these ambient critters wandering the world and not the trappable spawns

Not 100% sure as I’m at work, but sheep are included in the critter nest mixin, and they don’t spawn until pastures are placed. I therefore assume they are one and the same

ok did what i thought of was necessary
"mixintos": {
“stonehearth:scenario:scenario_index.json”: “file(scenario/scenario_index.json)”
in my manifest and created a scenario_index with my snowhare_nest

no errors, no effect

If it still doesn’t work, the easiest way to diagnose your issue would be to upload the mod to dropbox and share the link here.

We can then take a proper look at it.

i think im not familliar enough with the errors in the log file of stonehearth I always get 2015-Jun-18 18:22:02.934389 | server | 1 | resources | could not find resource for stonehearth/scenario/scenario_index.json while processing overrides for snowharemod. ignoring. and i dont know which resources
Is that a error in the paths ?


You’re missing an s


“mixintos”: {
“stonehearth:scenario:scenario_index.json”: “file(scenario/scenario_index.json)”

is wrong. Should be "stonehearth/scenarios/scenario_index.json : “file(whereeveryouputit/scenario_index.json)”

Is the trapper animal related to the critter nests?
Be sure to check that first. Otherwise you only have to add a new critter. And the trap picks your animal at random.

1 Like

thats what i wanted to do
but how can i add a new critter without overriding one ?

I tried to check where the trap spawn is located but the only thing i found was the reference to “critters” type entities

Not sure to be honest. I haven’t looked at it in any detail. Critter nests may only be used to create random terrain littering critters, so you could be right. They might not be trapper related at all.

Edit, hmm. The trapping grounds component just creates a critter, not a critter nest…

If you copied the rabbit.json

“mixins” : “stonehearth:mixins:critter” should be there.

Which makes it a critter.

At this point I usually poke @RepeatPan or @sdee to confirm :stuck_out_tongue:

1 Like

Yes, if you add the critter mixin, it will give the new entity the attributes of critters. We gave it to sheep at first, and they were getting stuck in trapper traps. Yay! :smiley:

The nests are currently independent of the trapping grounds; we have some plans in the future of increasing yield when there’s a nest nearby.


No, that wasnt working. Thats what i tried first

Because of that i tried to figure out where the trapping critter reference is.

Ok, i got i so far that the world generator accepts everything
but i got problems with invalid file path errors and i can`t figure it out

but for today i will quit. Two days of reading jsons and luacs and starting the game a hundred times is enough. Tomorrow i will go on to solve this seemingly little problem i hope.
Heres the error. Any suggestions of locating the file path would be appreciated std:execption:invalid file path snowhare.`
is that the file path in my manifest ?

New day old problems…still fighting with invalid file path errors…can`t find them

It is hard to help you with path file problems without seeing the files.

1 Like

“type”: “entity”,
“components”: {
“unit_info”: {
“name”: “Snowhare”,
“description”: “White and furry”,
“player_id”: “critters”
“render_info”: {
“animation_table”: [
“model_variants”: {
“default”: {
“models”: [


thats my snowhare.json
i tested this morning if my snowhare.qb is valid because i created it with stonevox and overrided the rabbit and it worked well

the paths are integrated in my mod as well so there should be no problems

@froggy got no active dropbox maybe i should get into the future and use it :smile: