Error occurs when trying to open building design UI


#1

Actually I’m not sure if this is a A16 bug…
I was building a 2-floor building, found the construction work stopped. When I checked what was going on, the bug popped.

##Here’s the snapshot:

##Bug Report:
1)
develop-2924 (x64)
…h/components/entity_forms/entity_forms_component.lua:353: assertion failed!
stack traceback:
[C]: ?
[C]: in function ‘assert’
…h/components/entity_forms/entity_forms_component.lua:353: in function ‘place_item_on_structure’
…/fixture_fabricator/fixture_fabricator_component.lua:266: in function ‘_place_item_on_structure’
…/fixture_fabricator/fixture_fabricator_component.lua:243: in function ‘_place_fixture’
…/fixture_fabricator/fixture_fabricator_component.lua:203: in function ‘_start_project’
…/fixture_fabricator/fixture_fabricator_component.lua:150: in function 'start_project’
stonehearth/services/server/build/build_service.lua:1217: in function 'add_fixture_fabricator’
stonehearth/services/server/build/build_service.lua:1258: in function ‘add_fixture’
…tonehearth/call_handlers/place_item_call_handler.lua:144: in function <…tonehearth/call_handlers/place_item_call_handler.lua:132>

  1. (There must be something wrong with the stack trace logging…)
    develop-2924 (x64)
    c++ exception: lua runtime error
    stack traceback:

##The steps I did which caused the bug:

  1. Clicked the ‘Place Building’ button
  2. Found that I should use the design buidling tool, so clicked the unfinished building
  3. And it happened.

##Save file:
I can’t upload the zip file as the site said I’m a ‘new user’… So you can download it from my website link @:
http://wizcas.me/downloads/1460956675600.zip