Error in time_tracker_controller. Citizens stuck in floor

this happened after a hour of play

here is a link to a pic with the problem

1 Like

this happens after about 10 minutes and the error is stacking up to 120 files :grin:

I was away from my computer for about 30 minutes with the game paused. When I came back and unpaused, several of my villagers appeared to be stuck. They just stood where they were without moving and continuing their work. I attempted a Save/Exit/Load to see if the game was recoverable. When I reloaded the game, these villagers are now standing with just their heads above the ground, and the game immediately threw the following error:

develop-2494 (x64)stonehearth/components/ai/execution_unit_v2.luac:59: bad unit transition “start_thinking” from "finished"stack traceback:
radiant/modules/common.luac:32: in function <radiant/modules/common.luac:32>
[C]: in function 'error’
stonehearth/components/ai/execution_unit_v2.luac:59: in function '_unknown_transition’
stonehearth/components/ai/execution_unit_v2.luac:84: in function '_start_thinking’
stonehearth/components/ai/execution_frame.luac:212: in function '_do_slow_thinking’
stonehearth/components/ai/execution_frame.luac:270: in function '_fn’
radiant/controllers/timer_controller.luac:28: in function 'fire’
radiant/controllers/time_tracker_controller.luac:9: in function <radiant/controllers/time_tracker_controller.luac:9>
[C]: in function 'xpcall’
radiant/controllers/time_tracker_controller.luac:9: in function 'set_now’
radiant/controllers/time_tracker_controller.luac:20: in function 'increment_now’
radiant/modules/timer.luac:6: in function 'self’
radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
[C]: in function 'xpcall’
radiant/modules/events.luac:78: in function 'trigger’
radiant/modules/events.luac:97: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>

1 Like

Was having the minions pick up some mean beds and got the following errors… copy/paste from game. Afterwards, the minions stopped working on a house.

develop-2494 (x64)
stonehearth/components/ai/execution_unit_v2.luac:59: bad unit transition “start_thinking” from "finished"
stack traceback:
radiant/modules/common.luac:32: in function <radiant/modules/common.luac:32>
[C]: in function 'error’
stonehearth/components/ai/execution_unit_v2.luac:59: in function '_unknown_transition’
stonehearth/components/ai/execution_unit_v2.luac:84: in function '_start_thinking’
stonehearth/components/ai/execution_frame.luac:212: in function '_do_slow_thinking’
stonehearth/components/ai/execution_frame.luac:270: in function '_fn’
radiant/controllers/timer_controller.luac:28: in function 'fire’
radiant/controllers/time_tracker_controller.luac:9: in function <radiant/controllers/time_tracker_controller.luac:9>
[C]: in function 'xpcall’
radiant/controllers/time_tracker_controller.luac:9: in function 'set_now’
radiant/controllers/time_tracker_controller.luac:20: in function 'increment_now’
radiant/modules/timer.luac:6: in function 'self’
radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
[C]: in function 'xpcall’
radiant/modules/events.luac:78: in function 'trigger’
radiant/modules/events.luac:97: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>
develop-2494 (x64)
stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
radiant/modules/common.luac:99: in function 'assert’
stonehearth/services/server/inventory/inventory.luac:223: in function '_check_entity_forms_of_new_item’
stonehearth/services/server/inventory/inventory.luac:95: in function ‘add_item’
…tonehearth/components/storage/storage_component.luac:133: in function ‘add_item’
…arth/ai/actions/put_carrying_in_backpack_action.luac:14: in function 'call_fn’
stonehearth/components/ai/execution_unit_v2.luac:16: in function '_call_run’
stonehearth/components/ai/execution_unit_v2.luac:185: in function '_run_from_started’
stonehearth/components/ai/execution_unit_v2.luac:128: in function '_run’
stonehearth/components/ai/execution_frame.luac:439: in function <stonehearth/components/ai/execution_frame.luac:439>

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:439: in function '_run_from_started’
stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function ‘call_fn’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function 'call_fn’
stonehearth/components/ai/execution_unit_v2.luac:16: in function '_call_run’
stonehearth/components/ai/execution_unit_v2.luac:185: in function '_run_from_started’
stonehearth/components/ai/execution_unit_v2.luac:128: in function '_run’
stonehearth/components/ai/execution_frame.luac:439: in function <stonehearth/components/ai/execution_frame.luac:439>
[C]: in function ‘xpcall’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:439: in function '_run_from_started’
stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function ‘call_fn’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function 'call_fn’
stonehearth/components/ai/execution_unit_v2.luac:16: in function '_call_run’
stonehearth/components/ai/execution_unit_v2.luac:185: in function '_run_from_started’
stonehearth/components/ai/execution_unit_v2.luac:128: in function '_run’
stonehearth/components/ai/execution_frame.luac:439: in function <stonehearth/components/ai/execution_frame.luac:439>
[C]: in function ‘xpcall’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:439: in function '_run_from_started’
stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function ‘call_fn’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/services/server/ai/compound_action.luac:117: in function 'call_fn’
stonehearth/components/ai/execution_unit_v2.luac:16: in function '_call_run’
stonehearth/components/ai/execution_unit_v2.luac:185: in function '_run_from_started’
stonehearth/components/ai/execution_unit_v2.luac:128: in function '_run’
stonehearth/components/ai/execution_frame.luac:439: in function <stonehearth/components/ai/execution_frame.luac:439>
[C]: in function ‘xpcall’

stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>
develop-2494 (x64)
stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/components/ai/execution_frame.luac:672: stonehearth/services/server/inventory/inventory.luac:223: assertion failed: tried to add iconic (422543 Mean Bed (iconic)) when root is already in inventory
stack traceback:
stonehearth/components/ai/execution_frame.luac:656: in function <stonehearth/components/ai/execution_frame.luac:649>
[C]: in function 'error’
stonehearth/components/ai/execution_frame.luac:672: in function '_exit_protected_call’
stonehearth/components/ai/execution_frame.luac:667: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:439: in function '_run_from_started’
stonehearth/components/ai/execution_frame.luac:101: in function '_run’
stonehearth/components/ai/execution_frame.luac:338: in function <stonehearth/components/ai/execution_frame.luac:329>
[C]: in function 'xpcall’
stonehearth/components/ai/execution_frame.luac:658: in function '_protected_call’
stonehearth/components/ai/execution_frame.luac:340: in function 'run’
stonehearth/components/ai/ai_component.luac:128: in function '_thread_main’
stonehearth/services/server/threads/thread.luac:90: in function <stonehearth/services/server/threads/thread.luac:89>
[C]: in function 'xpcall’
stonehearth/services/server/threads/thread.luac:89: in function 'f’
radiant/lib/env.luac:8: in function <radiant/lib/env.luac:8>

1 Like

heartling stuck on ground only head showing
Engine Error

  • cant move cant eat cant go anywhere, idk what cause he/she stuck on ground
    sometimes 7 days in game or 18 days in game. Save and reload didnt help

There’s scaffolding under the floor so I think she was standing on that when the floor was built. Is there anyway to rest hearthlings? Otherwise I will destroy her via console (muhahaha)

Props to Sral92x for the awesome storehouse design.

1 Like

Note I had no errors occur when this happened. I reloaded and tried to build it again and two hearthlings got stuck in about the same place.

This is odd, something I haven’t come across before - I just started up my A11 save, my workers are building a barn, and I have several crafters (carpenter, weaver, mason) helping, as I have nothing for them to do at their workbenches. I scroll around, make sure everything is in order, and come back to the barn and find my Weaver buried with only his head showing. I tried to assign some things to his workbench, see if that would unstick him, and it doesn’t. So I go to reload and I get an error sound and this message on my desktop (Stonehearth is up but if I try to return to the game it just says ‘Stonehearth’ in the upper-left hand corner)

Assertion Failed: sceneld <
_scenes.size()(…\source\horde3d\Source\Horde3DEngine\egScene.cpp:970)

Hitting OK closed Stonehearth and the message. I notice in the ‘similar topics’ it mentions something like this for Alpha 4, however without the error message. Anyone else experiencing this?

1 Like

My weaver was eating at the table when she finished and then stopped still. I saved, reloaded and then she was stuck in the floor same as everyone else. the table & chairs are 4 dining tables with 10 chairs arranged around them. the shortest end (the side that can only position 1 chair) is 2 squares away from a nearly full 20x20 storage area with all items in it. The weaver’s workbench is on the other side of the storage area with 7 thread in maintain, 2 fabric in maintain and 2 leather in maintain. Sorry no image, i am a new member to the discourse

Sorry for the following (dont know how to do spoiler thingys)

develop-2494 (x64)
stonehearth/components/ai/execution_unit_v2.luac:59: bad unit transition “start_thinking” from "finished"
stack traceback:
radiant/modules/common.luac:32: in function <radiant/modules/common.luac:32>
[C]: in function 'error’
stonehearth/components/ai/execution_unit_v2.luac:59: in function '_unknown_transition’
stonehearth/components/ai/execution_unit_v2.luac:84: in function '_start_thinking’
stonehearth/components/ai/execution_frame.luac:212: in function '_do_slow_thinking’
stonehearth/components/ai/execution_frame.luac:270: in function '_fn’
radiant/controllers/timer_controller.luac:28: in function 'fire’
radiant/controllers/time_tracker_controller.luac:9: in function <radiant/controllers/time_tracker_controller.luac:9>
[C]: in function 'xpcall’
radiant/controllers/time_tracker_controller.luac:9: in function 'set_now’
radiant/controllers/time_tracker_controller.luac:20: in function 'increment_now’
radiant/modules/timer.luac:6: in function 'self’
radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
[C]: in function 'xpcall’
radiant/modules/events.luac:78: in function 'trigger’
radiant/modules/events.luac:97: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>

1 Like

Heya. I’m using Alpha 11 early build on steam (buggy I know) and thought I’d share this.

I decided to build pretty slow (normal game, no mods). I made a little farming community. Only two buildings made, both just one story. Despite building slow I got up to 18 hearthlings. After a bit none of my workers or crafters were doing anything even though I had several tasks for them to do (plenty of logs and things to pick up around the village). I found them all and they were all just standing around with the hungry icon above their heads. I had more than enough food but they weren’t eating.

Trying to fix this I saved/reloaded. Then I tried exiting the game completely. After those didn’t work I tried moving them around as a party and tried town defense mode too. Nothing. Kinda strange.

Can you provide a screenshot?

Getting this problem quite often aswell… The bigger the town u have, the more i see it :frowning:
Its been ongoing with several patches/builds…

Wish there was a command to flush their task que, maybe they could solve it… ?

Hi, i’ve been having this exact issue too.

I got an error message that i can paste in:

develop-2494 (x64)
stonehearth/services/server/town/town.luac:54: attempt to index field ‘_task_groups’ (a nil value)
stack traceback:
[C]: ?
stonehearth/services/server/town/town.luac:54: in function 'create_task_for_group’
stonehearth/ai/observers/fill_storage_observer.luac:18: in function '_create_worker_task’
stonehearth/ai/observers/fill_storage_observer.luac:12: in function '_update_worker_task’
stonehearth/ai/observers/fill_storage_observer.luac:4: in function <stonehearth/ai/observers/fill_storage_observer.luac:3>

Here’s a screenshot I took. They were scattered all over just standing around hungry. I made them into a party and gathered them here then let them loose but they just moved around a little bit then stopped. A few made it as far as the crop fields then stopped as well. You can see a few have somehow fallen through the ground too. They will get out of the ground and move when prompted using the group tool but a few fall back in until only their heads are showing when let loose again. I really liked how my little farm was turning out too lol

2 Likes

is the bulk o your food perhaps in crates? currently hearthlings cant get food out of crates. (unless it was fixed in 2494)

edit: does red alert kick them out of this behavior?

Having watched the crushinator, I’d guess this is just too much thinking for part of the hearthlings. I think it’s performance related… How much was your net worth?

Oh wow, you got some people buried there, too :hushed:

2 Likes

Networth is 7289

Got an error too:

develop-2494 (x64)
stonehearth/components/ai/execution_unit_v2.luac:59: bad unit transition “start_thinking” from "finished"
stack traceback:
radiant/modules/common.luac:32: in function <radiant/modules/common.luac:32>
[C]: in function 'error’
stonehearth/components/ai/execution_unit_v2.luac:59: in function '_unknown_transition’
stonehearth/components/ai/execution_unit_v2.luac:84: in function '_start_thinking’
stonehearth/components/ai/execution_frame.luac:212: in function '_do_slow_thinking’
stonehearth/components/ai/execution_frame.luac:270: in function '_fn’
radiant/controllers/timer_controller.luac:28: in function 'fire’
radiant/controllers/time_tracker_controller.luac:9: in function <radiant/controllers/time_tracker_controller.luac:9>
[C]: in function 'xpcall’
radiant/controllers/time_tracker_controller.luac:9: in function 'set_now’
radiant/controllers/time_tracker_controller.luac:20: in function 'increment_now’
radiant/modules/timer.luac:6: in function 'self’
radiant/modules/events.luac:80: in function <radiant/modules/events.luac:78>
[C]: in function 'xpcall’
radiant/modules/events.luac:78: in function 'trigger’
radiant/modules/events.luac:97: in function '_update’
radiant/server.luac:19: in function <radiant/server.luac:17>

2 Likes

I have found a really bad work around to get the hearthlings to move, which is to go into and out of the pause menu, it jolts the hearthlings and they’ll work for about 10 seconds before freezing up again (not sure if this’ll work for anyone else) so i have to press escape every ten seconds to get them to do things… which is annoying. when watching the performance bars in the bottom right, lua is jumping up to 95%+ almost constantly, and only goes down when i pause it (then starts to rise again).

Hello,

I have the exact same problem with my stonelings now. (not doing anything)
Indeed the pressing escape solution works for every 10seconds or so.

And i also have 2 villagers stuck in the floor just like Shurakai has.

So i hope to see this fixed soon also.

Did you have a mine beneath where they got stuck ? I had this issue on a map where I build an underground city. Reloading the game, puts them back on the surface, at least that solved it for me. (Version 10.0)

Also I feel like I have read about this issue on some older topic. can’t seem to find it though.