Error every time i get to generating a map!

release-689 (x64)[M]
…rvices/server/world_generation/custom_landscaper.lua:30: attempt to call method ‘_initialize_determiners’ (a nil value)
stack traceback:
[C]: in function ‘_initialize_determiners’
…rvices/server/world_generation/custom_landscaper.lua:30: in function '__user_init’
radiant/lib/unclasslib.lua:270: in function '__init’
radiant/lib/unclasslib.lua:201: in function ‘Landscaper’
…server/world_generation/world_generation_service.lua:65: in function ‘create_new_game’
…vices/server/game_creation/game_creation_service.lua:150: in function ‘create_new_world’
…vices/server/game_creation/game_creation_service.lua:179: in function <…vices/server/game_creation/game_creation_service.lua:169>

i’m not sure what to do about this. i tried removing the mods i recently put in, nope, it still happens. so it’s not the mods necessarily.

Hi @Kitkat_Matt. See that “[M]” next to your version in the log?

That means you still have some mod.
Open the Settings menu while you are on the main screen, and click on the last tab (“Mods”).
See if you have any mod that you installed still enabled (checked).

well here’s the thing, when i deactivate EVERY mod it works just fine, it’s only when i activate mods, in general, that it does this. is there something wrong with the latest build that i’m not aware of that makes it incompatible with all mods currently released?

Maybe it is a biome mod. I still have to test the a20.

Maybe. I have no biome mods. Deactivating Frostfeast solved it for me.

I will post something about that soon, but when we switch Alphas it is safer to deactivate all mods, since modders can’t know if their mods are still compatible or not until they try them with the new build.