Doors not placing


#1

Summary:
Clay tunnel doors will not place
Steps to reproduce:

  1. Make clay tunnel doors
  2. go to custom building
    3)try to place door

Expected Results:
Door should show up and be placeable
Actual Results:
Doors do not place
Notes:

Attachments:

Version Number and Mods in use:
No mods alpha 15 released 543
System Information:


#2

How many Settlers do you have, This might be due to the Idle glitch…


#3

Hey there @Blackpanther140, welcome to the Discourse!

Doors cannot be placed from the custom building tool onto the ground, only into a wall. Have you tried using the item placement tool?


#4

So, in 543 in the desert bio, I attempted to place doors in a wall and the hearthlings built over the placement location. In latest 549 (I didn’t try in 543) I placed 2 doors in the same spot and the hearthlings then recognized the doorway opening and built around it.

The first time you place a door, it looks as if they door is ‘inside’ the wall and not really the way it would normally be obvious. Placing the 2nd door resulted in the door model being a bit more obvious in the intended wall…?

Anyone seeing the same behavior?


#5

100% confirm this, If you place it while still in build mode then it will work normally


#6

You had to place the door 2wice though right? Placing once results in non-placement for me still. I am however seeing a lot of the following graphical z-tearing within the blueprint model placed before being built.

I saw this issue pre 547 & 549 when attempting to ‘Re-place’ a slab floor that didn’t get built for whatever reason but the blueprint model of the slab floor was still there. Once I re-placed the slab floor in design/build mode on top/over the old floor blueprint, the result was visually the same. I think this is the culprit to the door issue. If I place 1 wall with the wall grow tool, the result visually looks like I have placed 2 wall on top of each other, funny that in order to get a door placed the user is forced to place a door 2wice in the same spot? Probably need a separate bug…

Here is a pic verifying door placement -

You can see in the pic the obvious doorway, but instead of the door obj. image you see the wall you are trying to place the door in. After placement here is what it looks like -

You can see there seems to be NO doorway here, verify by re-selecting to place a door from the build menu and hover the placement tool pointer over the original location to see the original placement.

Jomaxro, if you need a bug let me know.


New wall won't build but I've already built 2
#7

Something seems odd with those walls…the texture makes it appear that the walls are overlapping something (like themselves), which could explain the double door issue, but I am not sure. I tried placing a wall pattern like that in my build and couldn’t get that texture to appear…@not_owen_wilson likely has more details.


#8

If you need game saves or templates let me know!


#9

Actually, I think I just locked it down…

Repro steps-

  1. Launch latest 549
  2. Once in game enter build tool set and select 1st floor grow tool
  3. Place a single row (1 voxel wide) of floor.
  4. Select wall grow tool and place wall
  5. Observe wall placement closely (usually you CANNOT tell because its usually a solid (mono)color)
  6. Place Door into wall
  7. Observe you can now see the graphical in-fighting(z-tearing) due to the interaction of the new (not same color) object

Notes-
It’s my personal opinion that the game is attempting to place 4 walls into the single row of floor previously placed. There is no inherent rule outlined for building walls for a ‘building’ that is 1 row wide.

Also this issue is easier to see when using the design tiles


#10

PS - @jomaxro, I am a beast!


#11

Hey @MickDodge, sorry for the delay…it’s been really busy IRL lately.

Anyway, I cannot complete your repro steps :frowning:. The custom building tool will not place the autowalls on a 1 voxel wide floor…


#12

NP! Easy fix… my explanation wasn’t the best…

jomaxro 1 voxel wall.zip (1.7 KB)

Note the visual difference of the 2 doors. The door on the left is a single placed door, where the door on the right is actually 2 doors placed in the same location.


#13

OK, now I can repro it. Seems I needed at least 2 single rows of floor to reproduce the issue. Paging @not_owen_wilson to see this next week…


#14

Nice! yeah, again, apologies for crappy repros