Crafting glitch with ACE mod

#1

Summary:
I can’t seem to craft nor seem to be able see my cued items

Steps to reproduce:

  1. select build item and click CRAFT
  2. builder dude gets the resource
  3. BUILD THE FREAKIN’ ITEM

Expected Results:
Crafted item

Actual Results:
Lost Resources and no crafted item

Notes:
and i have no problems before i added them both together

Attachments:
i dont remember how to do this XD

Version Number and Mods in use:
i have the ACE mod and Nordling mod installed together
Both being newest version

System Information:
8 GB of ram(6 usable)
Laptop (intel graphics)
Intel I5

#2

Oh yeah and this shows up
release-949 (x64)[M]
…ices/server/crafter_info/crafter_info_controller.lua:134: attempt to index field ‘entity_data’ (a nil value)
stack traceback:
[C]: ?
…ices/server/crafter_info/crafter_info_controller.lua:134: in function ‘_format_recipe’
…ices/server/crafter_info/crafter_info_controller.lua:72: in function ‘_create_maps’
…ices/server/crafter_info/crafter_info_controller.lua:22: in function ‘post_activate’
radiant/modules/commons.lua:306: in function ‘create_controller’
…ervices/server/crafter_info/crafter_info_service.lua:97: in function ‘add_crafter_info’
…ervices/server/crafter_info/crafter_info_service.lua:106: in function ‘get_crafter_info’
…ervices/server/crafter_info/crafter_info_service.lua:92: in function <…ervices/server/crafter_info/crafter_info_service.lua:90>
[C]: ?
[C]: in function ‘trigger’
radiant/modules/events.lua:55: in function ‘trigger’
…tonehearth_ace/monkey_patches/ace_player_service.lua:9: in function ‘add_kingdom’
…vices/server/game_creation/game_creation_service.lua:129: in function <…vices/server/game_creation/game_creation_service.lua:124>

#3

Was this in multiplayer?
I see an error I recognise from banto’s stream that happened when a player tried to join? But it went wrong?

#4

No it was not. But i think its a mod conflict i will do more testing and sorry for later response i was asleep

#5

No worries man we are all on different timezones lol. If you list the mods we can help think

1 Like
#6

Tuhalu
All regular stonehearth mods(including debug) are on
Beam
Signery
Settlement decor
Followers of remus
Nordling mod
Minecart and rails
Lostems
Homf
Homesweethome
Extra map options
Furniture expansion plus
Fortify
Stonehearth cafe
Cattect extended colors
Brewerymod
Fruit and animals (box o vox)
Autoharvest
Fisher job plus archipelago biome

#7

Oh and i dozed off again lol(edit)(i think i might have kept the game on while i was dosing off lol. I was on the other side of the map when i woke back up)

#8

I’m sure the caffe has some buggy code, and it’s needed for the brewery mod.
and a few of the other mods, by memory, don’t like playing together too much but I don’t have details I fear :stuck_out_tongue:

#9

Alright i will try to disable the brewery mod and see if that works. thank you!

#10

tell my if it has worked xD

#11

It has now worked thew cafe mod and the dependency were removed and now work perfectly. Thank you very much! :smile:

#12

or the mod config with ace and all that work now (lol)