Crafters sometimes unable to craft workbenches

Summary: While playing Alpha 13 I finally decided to make a weaver however no matter what workbench I try to make they refuse to make one.

Steps to reproduce:

  1. Make a Weaver class
  2. Open crafting menu
  3. Try to craft a Workbench, Spinning Wheel, or Loom

Expected Results: Some kind of workbench to be crafted

Actual Results: Idle Weaver

Versions and Mods: Alpha 13

System Information: Windows 10 x64bit

1 Like

Hey there @TheDerpySupport, when you ask the weaver to craft a workbench, does it appear in the “queue” on the side?

Yes however she usually just sits there.

OK. Definitely an issue. Paging @sdee to come take a look…

1 Like

I’ve seen this happen, too, on other crafters. I’m still trying to figure out why it happens sometimes, but not all the time.

I’m having the same issue, I’ve demoted and promoted a number of villagers to the weaver position but none have made any of the crafting benches. The benches show up in que and I have a villager in the weaver class but they ignore it. I’ve destroyed the spindles associated with the promotions and used new one to promote, still no joy. I’ve restarted the game a number of times as well to no avail.

Here’s my save file…

1 Like

Updated to develop-2699 (x64) with no progress until I checked “Mine” and “Job” under Work Orders. The weaver then made the crafting tables… WOOT!!

EDIT: Would like to note that I didn’t try this under the previous build and it may well have worked there.

Title: Weaver Bugged

Summary: After being promoted the weaver will just idle around never building any workstations no matter how much you wait or try to shift around their work queue.

Steps to reproduce:

  1. promote a worker to weaver
  2. assign weaving job
    3)nothing happens

Expected Results: weaving I would hope lol.

Actual Results: nada

Notes: Is this a commonly reported bug or just me?


Versions and Mods: Newest steam unstable release (alpha 13).

System Information:

I had to use hearthling therapist and turn off all checked boxes then check them again to turn him back on.

Hey @sdee, is @bloodist’s solution reproducible on your end?

The checking on and off of the job ai’s in hearthling therapist seems to be a good fix for now until they can patch the problem. Thanks for bringing that up.