[Con] The mystery of the misplaced fog of war

So i found the world a smidgen darker then i normally do. And I like things well lit up so i decided to zoom out and found this.

Huzzah for slain goblins!

Now when i loaded first it showed 65 error messages that i clicked away. However! After reloading it did not fix the problem and showed the same (I’m assuming) 65 errors. (The errors could be unrelated. So far no one ells have reported error messages along with this bug.)

Not sure what ells could be of use. I played it yesterday. but when i loaded it today this happened. Has anyone ells foun this problem?

Happy hunting!

1 Like

I do not have the 65 errors pop up but I have the exact same problem, the left hand side of my map has no fog of war, but where my village is, is in complete darkness. This is on release-256 (x64). restarting the game and changing graphics options (lighting etc.) had no effect. This was the first time I had loaded the map since starting it the night before.

I had the same build.

thanks for the report and confirmation… [tagged]

although I am positive I’ve seen a screenshot like that before… perhaps for another bug?

I tried to search for fog of war and dark and such but found nothing.

1 Like

Found a few different bug reports similar to this.I had a world, 7 hours worth of work, Saved. Closed re-opened, And this bug happened :frowning:

A old work around I used to use was save. Start a new world, Save that world. load up world that was covered in fog and it would have fixed. But sadly it doesn’t seem to be working for me in Alpha 9.

Error 404:

“Fix for unexplored region being misplaced on load occasionally”

not found.

ok, ok, I should go to sleep now…


When loading a recent save game, the camp is covered in darkness. This dark is similar to what ‘undiscovered’ land looks like.

It persists between saves and reloading. It doesn’t seem that I can upload an image yet, so I will link it below.

It just happened on the last load from a save. This town has had significant path finding problems since I started attempting to remove the top of the mountain I am next to, but I am not positive it is related.

Save located here: Dropbox - 1427226863439.rar
Image: Dropbox - 2015-03-27_00001.jpg


hey three @Dragoon209 … does your lighting issue look similar to this report?

oh, and feel free to toss an image up to imgur.com and we’ll get it embedded for you, until you’re able to do so yourself… :+1:

It does look similar! I didn’t think to search ‘fog of war’, whoops!

I did not get any error spam during play as mentioned by the first post of your link.

Imgur Link!


no worries! :smile:

it does sound similar enough to the other comments in this thread for a merge though… thanks for the report! :+1:


Just loaded a game that was working fine previously, half the map stays dim regardless of day or night and the other half is lit. Screenshot here

firstly, welcome to the discourse :smile:

secondly, hmm i know i saw something like this before not sure where though, i will try and find it later.

Moved you over here @waldo :slight_smile:

1 Like

Hi everyone,

I’m also facing this bug. I also didn’t get any error message when it started or loading the savegame.


hey there @Finvana … welcome aboard! :smile:

thanks for the confirmation/screenshot… :+1:

Hey there. I also got this bug. Played the new Alpha 9 at the beginning of the week. Loaded the game this morning and found half the world is darker than the other half. It also did not help to load another save game of earlier. Also tried adjusting grfx settings. Did not help.

So I finally got a game going where I’ve been able to avoid the idle workers bug (thank god!!), but now I’ve noticed a weird lighting bug. I’m not sure when this started, but it wasn’t from the first day in this world, probably about day 10-ish.

I have some pictures of the bug as well as an error message I get when I load the save:

DAY (as you can see, in daytime, half the map looks like night)


Explore Alex Lynn

I have had this bug over and over the last days… since the alpha 10 was first released, and pulled againg…
I’m running the current latest build… and its happening 4 of 4 times now, I’ll take a break from stonehearth unless somebody finds a fix, so I can play my save games again or atleast not see this bug again :frowning:

The fog of war issues should be resolved in the next patch. Thanks for the help!