[Con] Stockpiles miss clicks

thanks… can you toss up a screenshot? if you’re playing the Steam client, just hit F12… :+1:

sorry i dont know if you miss under stood, but i am (not) getting a red bug list (like sometimes that has happened with other bugs)

bah, apologies! I did indeed misread…

2 Likes

one thing i will do (if you still need it)… i need to start a new save anyway, due to the cant make a shepherd bug in another post i made… but more info on the stockpiles not being solid… when i hover over the text… (not) items in the stock pile, i will get the bag icon instead of the arrow icon, if you want a screeny of that, let me know, thanks

UPDATE:

ok… this is user error (for anyone else experiencing the same bug, here is the fix)

After creating a stockpile (but whilst still in the stock menu) right click, then the UI is no longer a ghost

Edit, i guess this topic can now be closed @SteveAdamo

interesting … @8BitCrab, does this work for you as well? I am still confused on how this is (not) working, as I cant replicate myself…

I think it’s indeed bugged, I made some 1 square sized stockpiles when trying to click in the stockpile UI.

1 Like

that’s what happens to me.

[quote=“SteveAdamo, post:10, topic:11000”]
interesting … @8BitCrab, does this work for you as well? I am still confused on how this is (not) working, as I cant replicate myself…
[/quote]i will check later when i get the time. and it doesnt always happen, just sometimes and im not sure what causes it to happen.

3 Likes

sorry i dont know how to quote sorry… i never meant it happens all the time… it only appears to happen when you are clicking the text not the check boxes… i will await @8BitCrab confirmation

2 Likes

just highlight the text and it should come up with “quote text” click that and it will open up a reply with the highlighted text quoted.

[quote=“Barney324, post:13, topic:11000”]
i never meant it happens all the time… it only appears to happen when you are clicking the text not the check boxes… i will await @8BitCrab confirmation
[/quote]huh? sorry but i don’t get what you mean :confused:

1 Like

basically… the stockpile bug… it is only a ghost on the text and the all/none check boxes… the other boxes are not ghosts

I had it happen when trying to click the ‘x’ button to close the stockpile window.

i have made a *video bug journal * which can be found here [BUG/S] Video Journal, and explains the stockpile bug (and otheres) in more detail

I can confirm as well. I’ve also noticed the same thing happening with the mining tool. Keep digging out holes in the middle of town :frowning:

2 Likes

all of the ui is not solid… also the jobtree and the charsheet ^^ only the buttons ^^

It’s like the click area is just the bottom of the controls… For example, I can click the ‘x’ button for closing the stockpile UI only if the mouse is at the bottom of the ‘x’.

1 Like

like i have discript it in an other topic its like the solid isnt compare like the view - you can see this easy when you go to harvest at the upper side its the notice and ca 100px down you will find the real solid box ^^

1 Like

If something clickable is behind a menu button/clickable it will be clicked instead of the menu button/clickable.
Example:

The mouse cursor is on the weaver icon but the bed is highlighted and if I click I will click on the bed not the weaver icon.

1 Like

thanks for the report… I know I’ve read something similar…

is it close to what’s reported here?

2 Likes

Seems close but I am not sure.

Edit:
Reading through the comments, looks like it is the same bug.

1 Like