[Con] Assertion Failed: requiredSize - protocol.cpp

Any ideas? After 51 game days (21st day of Dewmun) playing dev2176x64 I’m getting the following error trying to load saved games:

Assertion Failed: requiredSize < SEND_BUFFER_SIZE(…\source\protocols\protocol.cpp:54)

stonehearth.log (12.7 KB)
gfx.log (4.1 KB)
chromium.log (174.2 KB)

Windows 8.1 Pro 64-bit (6.3, Build 9600)
32 Gig installed RAM
Intel® Core™ i7-3820 CPU @ 3.60GHz (8 CPUs)
Graphics: AMD Radeon HD 7900 Series

1 Like

Playing pretty well this morning on Intel 64bit machine. Got to day 10 (after defeating Goblin camp), then game crashed.

Tried to load most recent save game and the loading bar never went past half - then Assersion Failed.

Noticed while game was froze that there are THREE stonehearth.exes running in task manager. I only ran the game once, so it’s not multiple instances. Every time I ran the game, it shows up 3 times. Maybe this is intentional, who knows.

If it helps, I can upload the bunged up save game. (dev build 2310 x 64)

thanks for the confirmation @NonBritGit … [tagged]

I just got this error after trying to load the game after crashing (sudden stop) also have 3 stonehearth.exe running in the task manager.

ver 0.1.0 dev 2310 x64

Town has over 10 people game begins to stutter and crashes. When loading a send buffer error appears.

Edit: x64 Win7 16GB Ram (3xHD7970)

Just to ask, cause this can cause it. Did you try and build something that conflicted, you tried to erase it and or remove the build. Causing an error to pop up. Then saved to go back and erase it again?

1 Like

I was moving stock piles around and mining at the same time.

Okay so no builds? Do you have a mod loaded?

Thing is if you have a conflict build that didn’t erase or remove correctly or have a mod loaded then remove that. it can cause an issue trying to bring your game back up like that.

Other thing is, if you tried to load a game after updating, that can happen too, you might have to start a new game.

1 Like

I was trying to open the carpenter’s craft window in order to tell him to create 2 new tables. When the unit was selected, his unit info UI appeared but clicking the saw icon beside his name did not bring up the screen that would let me select what I wanted him to create. Clicking on the icon didn’t produce an error, it simply failed to generate any reaction from the unit (as if the command wasn’t being registered).

Steps to reproduce:

  1. Build a Huge town with 17+ citizens, (i’ve done it in 14 days, have 7 crafters and a ton of resources…
  2. save the game and it will reacha point eventually where you can’t load it anymore

Expected Results:
I expected the saved game to load

Actual Results:
I’ve got this error message:
Assetion Failed: requiredSize<

I was playing in normal speed beacuase the game crashes when i issue more than 10 items to be palced in 2x speed. And i’m in peaceful mode. Also, i was playing more Dwarf Style building the base inside a cave instead of making buildings.


Here’s the saved game that can’t be loaded, it’s uploaded to my Gdrive, and here’s the download link:


Versions and Mods:
I’m running Stonehearth Alpha9 v0.1.0 x64 develop 2310 and have no additional mods running during this save game.

System Information:

Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150202-1526)
Language: Spanish (Regional Setting: Spanish)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: G1.Sniper Z97
BIOS: BIOS Date: 05/30/14 12:45:07 Ver: 04.06.05
Processor: Intel® Core™ i7-4790K CPU @ 4.00GHz (8 CPUs), ~4.0GHz
Memory: 16384MB RAM
Available OS Memory: 16222MB RAM
Page File: 10681MB used, 21758MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode
Card name: NVIDIA GeForce GTX 780 Ti
Manufacturer: NVIDIA
Chip type: GeForce GTX 780 Ti
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_100A&SUBSYS_36281458&REV_A1
Display Memory: 4095 MB
Dedicated Memory: 2994 MB
Shared Memory: 1101 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: BenQ GL2250H (Digital)
Monitor Model: BenQ GL2250H
Monitor Id: BNQ78A1
Native Mode: 1920 x 1080§ (60.000Hz)
Output Type: HDMI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.4752 (English)
Driver Version:
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 2/5/2015 22:01:44, 17253848 bytes

Thanks!! i hope this helps!!

1 Like

Well I’ll be gawd damned. Over 10 folks and the game save won’t load. I’ve had a game going all morning and was able to save new all along (even with 11 peeps), but the second I tried to load one of those saves, CRASH. Went back and loaded a save with only 10 peeps and it loaded just fine.

Edit: just attempted to load up a 10 player game save at home on my AMD rig and the loading bar gets to about 80% before the game just… goes away… No windows crash screen, nothing.

Same with several game saves made to day on the intel 64bit machine. Could there also be a compatibility issue between 32 and 64 bit game saves? Anyway, I’m out of ideas how to keep this game running.

Stonehearth v0.1.0 dev.2310 log crash and saves

Image - Stonehearth Assertion Failed

did you guys try reinstalling stonehearth? or if you’re using steam checking the integrity of the game cache?

It does not help. The installation was clean and working save, if you just overwrite without changes to the game, it gives an error. You can check yourself
upd: its end. I cant load overwritten game
End of Stonehearth


For a few games now, when I load a save that is after Day 8 of Dewmun it will load halfway then throw an Assertion Failed: requiredSize < SEND_BUFFER

If I load the saved game from Day 8 Dewmun, I do not get the error. But if I create a save file again after that day (doing nothing extra) and try to load it, it will give that error again. I started a new game, just in case it was something in my previous game that corrupted, and it is happenned again, cannot load saves after Day 8 of Dewmun.

Error happened for 64 bit versions and Before these I was able to load saves from days in Raimun with no issues.

I’m on Windows 8.1 64bit
Intel i7 3630QM 2.4GHz
NVidia GeForce GT 650M

Mods: Stonehearth Cafe/cookmod and Panabsorbium Armor

Here is the log file from my most recent attempt to load the save file.
stonehearth.log (14.4 KB)

I have made it to Day 21 of Dewmun without exiting and loading the game and it plays without issue. I just need to sleep :slight_smile: I have 20 hearthlings and do not accept anymore beyond that.

I’m not sure where to put these reports anymore and it seems like the devs are on vacation after A9 dropped, so I’ll just drop this here.

Release 256 x 64bit on my 64bit Intel machine plays quite well and autosaves just fine (oh, buti can’t place any building on this machine - info in another thread). Quite the improvement otherwise!

My running 256 in 32bit mode on my 64bit AMD machine is the same old story though, except now I can’t get past day 5 or 6 before autosave stops working . At that point you can’t manually save (or save new) either, so it’s a dead duck on my main machine.

Last time I got this mammoth wall of errors before the game crashed.


When I tried to load my game, it threw up this error halfway loading the game, it crashed imediatley after that.

Day 7 of rainmun, 8 hearthlings and about 120 buildings and very,very limited mining.

I am playing in build: Alpha 9 x256 64bit

Window 7 Pro Service Pack 1 64Bit
Intel Core i5-3570K 3.40 GHz
Nvidia GeForce GTX 660

No Mods

When loading a savegame this error pops-up halfway during loading

Expected Results:
The file loads normaly.

Actual Results:
The file does not load and throws this error.

I have been doing a lot of mining (no IM-cheating!) and the many enemies spawn but I do not engage them unless they attack me.

I haven’t tested this in alpa 15, but as soon as the official release hits steam, I will do that.

stonehearth.log (186.3 KB)


Version Number and Mods in use:
A14 - Release-524(x64)
No Mods but I did modify the Stonehearth.smod in order to get rid of the ‘Timer’ bug, when you get passed a year.

System Information:
Windows 7.1 Professional 64 | Intel i5-3570K | 16GB System Memory | NVIDIA GTX 660