Chopping trees have apparently become illegal

Summary: Ever since the update yesterday, my Hearthlings are not very keen on chopping wood. And it’s become progressively worse as the game carried on. In the beginning I could be lucky that they’d maybe chop at few times on a tree before loosing interest, if they need the materials. But right now, even as i have an unfinished building, and my carpenter is lacking wood for crafting, they are completely ignoring the trees I’ve marked for chopping. I have a Tree farm even they won’t touch.
I have tried stopping every job on the map, and selecting the trees again. I have tried to stop the workers from hauling, and all they do is default to idling or resting by the fire.

Steps to reproduce:

  1. Deselect trees to chop.
  2. Reselect trees to chop

Expected Results: Hearthlings would chop down the trees

Actual Results: Hearthlings doing other tasks, or resting by the fire or idling is hauling and building is disabled.



Version Number and Mods in use:
Version v0.9.66.6e

Autoharvest Mod
Combat Dash
Glowy Windows
What’s stuck

System Information:
Windows 10 Enterprise v.21h2
12th Gen Intel(R) Core™ i5-12400F 2.50 GHz
64 GB ddr4 RAM
Nvidia Geforce GTX 1060 6BG

Chopping trees, along with any other kind of “gathering,” is performed with the Haul work order, so disabling Haul will disable them from chopping trees.

Good to know. I have however tried both with and without the haul toggled on. And the result is more or less the same. If I’m lucky one random hearthling will chop a tree once every real time hour. When you’re missing wood for 2-3 separate tasks, the Carpenter at least should go and chop trees. Hm it might coincide with another few troubles I seem to be having.
1: My hearthling refuse to haul items to storage, many resources is just abandoned on the ground and doesn’t count to the overall town inventory.
2: my hearthlings destroy my food. I noticed I was bleeding food, hard. Especially cooked foods. I noticed that when hearthlings pick up food, both from cold storage and the community pot. Several of them just keep picking up food, where it just disappears in to thin air I lost 23 prepared food to 1 Hearthling who just emptied my cold storage and then ran to the Pot and did the same, and then ran and got a basket of corn to eat.
Don’t know if any of those two could be related to my original problem.

Just wanted to reply, I’ve experienced something similar. If all the hearthlings get caught up on “regular” hauling, they seem more likely to chop trees, but I have run out of wood multiple times with trees marked to chop. I’ve also had a similar issue where my engineer just chooses not to repair my turrets/traps. I would expect this to be under the “job” category, but turning off hauling just leads to them being idle, not repairing.

Are they crafted turrets/traps, not the disposable (non-repairable) ones you can get from a merchant?

On the engineer, I realized while it said “idle”, it seems to be it just says idle until they get to the trap/turret; the status doesn’t update until they are actively repairing. Because engineers can mine, they were just always across the map mining.