Carpet blueprints floating in the air

Carpet blueprints stuck in the air for many days, workers doing nothing to move the carpets to the desired locations.
No way to remove the highlights/holograms/blueprints/hitboxes of the carpets.
Steps to reproduce:

  1. Place an object in the ground. A table for example.
  2. Place a carpet “under” the object
  3. Carpet blueprint/highlight jumps on top of the object
  4. Carpet is not moved to the desired “laggy” location on top of the object. Unable to delete the hologram of it it.

Expected Results:
Expected result is for the carpet to go under the object. Not on top of it.

Actual Results:
The carpet highlight floats above the object with no futher actions.

It seems it happens in both cases

  1. The object (table) is placed before the carpet. Meaning the table has been there for a moment and then the carpet is placed “under” it.

  2. The object and the carpet are placed in the same time. So they both are highlighted in the same time. And the object is transported first which results the carpet being unable to be placed in the desired location.


Version Number and Mods in use:
Newest one, 0.16.0 & No mods in use
System Information:
Windows 10
2x 2,5GHz
1780mb Video memory
6GB Ram

Well this diffidently seems to be a bug. The only thing I am able to comment on is.

have you been able to use the console command (crlt-alt-c) destroy command to remove the ghost image?

Sounds possible idea. I will try it tomorrow and tell you the results.

I think the carpet is just being placed on top of the table’s collision box.

I don’t know if it should work the other way around (lifting the table so it gets placed underneath). I recall seeing hearthlings being lifted upwards when another hearthling placed an item (for example a bed) where they were standing, but with items it might be different =/

Actually, it’s just ctrl + C to open the console. No Alt needed :smile:

That is good to know. I guess they changed that in one of the alpha and I didn’t see it. it used to be ctrl-alt-c at one point and I just stayed with it. :smiley:

Okay, I tried to use the destroy command, it says it was successful but it still doesn’t do anything. Any other ways to help me out?


Make sure you have selected the ghost before using the destroy command. :sweat:
I reproduced the issue and was able to destroy it with the debug tools without problems.

1 Like

Yeah, I selected it :stuck_out_tongue:
But it did nothing, it just unselected itself and didn’t do any futher actions. But anyways I’m starting a new village. But if i come across that same problem again and if the command doesn’t work I will be in contact.