Can't close a fenced area - fences end up floating

I was trying to connect a fence at a lower elevation to a cliffside and the fence ended up floating in front of the cliff. I tried making ladders all around the floating object but the workers still could not reach it. I was wondering if this was a known issue and if there’s a command in the console (default key `) that allows us to remove an object.


UPDATE: I was able to remove the fence after building six more ladders but I’m still unable to close off the area with a fence. Tried with a different cliff side and it the fence still floated up. Also, is there a list or page of what we can do with the Stonehearth console?

hmm… keyboard commands are on the wiki (I believe), but I’ve never heard of folks using the console to issue commands…

1 Like

Using rp_console it would be possible (I think I’ve even implemented a “delete” command). However, RP isn’t working in the current Alpha. A proper port using Jelly (basically jelly_console) is planned but I cannot give you an estimate.

The short story is that yes, it is possible to remove these things - if you want to get a solution quickly, create your own “Delete this object” command and mixinto it to the fence. That would give you a command to delete it (and any other fence for that matter). I believe that this should work even in saved games, but I won’t guarantee anything.

You can select the fence by clicking on it, then typing “select” to console, then typing “kill”

With clicking the item and typing “destroy” in the console should suffice.

But now we have an in-game tool to destroy items, remember? :wink:
I think it was in the harvest menu…

This bug report has derailed enough :disappointed_relieved: