[BUG]? Keep getting this error loading save

As title says keep getting this error when loading save game, doesn’t seem to affect anything that I can tell and I’m not sure what is causing it, be it stonehearth or mods, it’s the Rayya’s campaign, latest steam release, latest release of Aviex’s [Alpha18] Enchanter Class/Mithril Weapons Mod+Enchanter Expansion Mod.

release-663 (x64)[M]
…ices/server/crafter_info/crafter_info_controller.lua:26: attempt to index local ‘job_info’ (a nil value)
stack traceback:
[C]: ?
…ices/server/crafter_info/crafter_info_controller.lua:26: in function <…ices/server/crafter_info/crafter_info_controller.lua:18>

release-663 (x64)[M]
c++ exception: lua runtime error
stack traceback:

Any ideas?

I wonder if it might truly come from @Aviex mod, since it adds a new job…

Yes, I don’t see any crafter_info_controller on the stonehearth / rayya’s children mods.
It probably comes from elsewhere. :slight_smile:

Hmm, can you upload the save file?

I mean it could be anything, since I’ve been pretty much rapidly changing stuff on the enchanter mod and you’re loading an older save, I’m not sure what would give the error though.

load error.zip (5.4 MB)
Started a new Rayya’s campaign, same error pops up loading, Only happens with the Rayya’s

Did you take all mods out and see if it still occurs?

Not sure if any of my mods would cause this, I tested the enchanter almost entirely using RC(since potter is obtained early for making blank runes).

Crafter info controller is in stonehearth.smod so I’m up in the air.

Where? I haven’t found it, in fact there’s no controller in stonehearth / rayyas whose name ends with “_controller”, I think.

Then that’s not from these mods. If only the full path appeared in that error, we’d know from where it is coming.
Do you have any other mods, @Unatan2 ?

Here’s image of my mods folder:

Could it be smarter crafter

1 Like

Confirmed. That controller is from the smart_crafter mod. @Drotten, any idea?

It’s indeed from the smart crafter mod. I have a hard time reproducing the error, though I have seen that error popping up before some mod update; could you perhaps try and download the newest version and see if that works out for you?

If you still get these errors, I’d love to hear some reproduction steps so I can track this one down. Thanks!

1 Like

Still getting it, used the current dropbox smart_crafter.smod as of today 9/26/2016


  1. Start RAYYA’s campaign
  2. Do stuff, ie. start creating camp
  3. save game
  4. exit to desktop
  5. start game
  6. Load RAYYA’s save
  7. Game starts, Get error

Mod list:

Windows 10 64-Bit
Alienware R4
Intel® Core™ i7-4820 CPU @ 3.70GHz 3.70GHz
GeForce GTX 760 (2)


Fixed the bug in the latest version of smart crafter. Thanks for the awesome repro steps! (And for using my mod) :slight_smile:

1 Like

Hello, Im still getting this bug today:
release-663 (x64)[M]…ices/server/crafter_info/crafter_info_controller.lua:42: attempt to index field ‘entity_data’ (a nil value)stack traceback:
[C]: ?
…ices/server/crafter_info/crafter_info_controller.lua:42: in function 'post_activate’
radiant/modules/common.lua:506: in function ‘create_controller’
…ervices/server/crafter_info/crafter_info_service.lua:15: in function ‘add_crafter_info’
…ervices/server/crafter_info/crafter_info_service.lua:23: in function 'get_crafter_info’
smart_crafter/smart_craft_order_list.lua:20: in function 'add_order’
stonehearth/components/workshop/craft_order_list.lua:74: in function <stonehearth/components/workshop/craft_order_list.lua:68>

It pops up once when the game goes to the main menu, and then pops up again the moment I try crafting something.

Ive downloaded the latest update 10 minutes ago.

Thanks. :slight_smile:

edit: if its any help, here is my mod folder:

1 Like

What’s with all these bugs that are suddenly popping up now in my mods…

Thanks for letting me know, I’ll take a look at it! :slight_smile:

Edit: What were you doing before in order to get this bug?

Opened the game just to make sure.

The moment the game gets to the main menu, I get the error.
After loading up the game and trying to craft a workbench, I get the error again, and the workbench doesnt get crafted. Basically I cant craft anything.

OK, it sounds really suspicious to me when the error occurs at startup (which I assume you mean when you say the game gets to the main menu).

When you get the error again: do you start a new game, or load a saved game?

Removing the smod solves the issue and Im able to craft again.

Im loading a saved game, but the first time the error occurred was when I started a new game.