[Bug?] Caravans Stop Showing Up R130

Not sure if this is a bug; however I have been playing for 60+ minutes (probably around 70) with no people show up. Is there the opportunity for this to happen and it not be a bug? It started when I moved over to r130. The game was started in r127.

If you mean that your original settlers aren’t visible… yay for incompatible saves I guess. It’s annoying, but your best bet every time there’s a new build out is to start afresh.

if it is what teleros means than yeh incompatible save file…

Otherwhise if it is like no scenario messages. Than it’s the same thing that happened to me on my stream yersterday…

absolutely… unless otherwise indicated by the developers, this is just a good rule of thumb when testing software releases… :+1:

1 Like

From what I’ve noticed caravans don’t show up in the peaceful mod in R130.

1 Like

Sure starting over is the ideal path; however during a lets play series that is not always an option. I still want to report as it sounds like we do have a bug if we have 3 people reporting very similar issues.

The one different is I am not in peaceful mode where @jellevmourik is.

@Sweeck sorry I missed your stream had to work late in meetings :(, were you in peaceful mode?

I also did see a flash of the scenario button when loading up my save last night but it went away, I tried to reload to get it back; however that didn’t work. I will recheck my footage once it is down uploading and see if it was my mind playing tricks on me.

I have - literally - just tested this (vanilla r130), and found it working fine. Peaceful mode, town value of ~5.9k, and a carpenter* turned up.

*Actually it was just a carpenter’s head, but who’s counting?

Edit: More details…

2 Likes

No worries Krovikan, I’ll be streaming again tonight. Feel free to hit us up whenever ya can :slight_smile:

Anyway, I did not play on peacefull mode no… I might do one the next time my save dies, but it’s fun fighting of those goblins!

here’s the save I’m talking about:

EP.1

EP.2

Ya, my recent video has the notification alert flash for less then a second onload, not sure if that means their is something stuck on the back end? Again I couldn’t reproduce this with a reload.

After 10 days the trader stops coming. I left my game running and for some reason the trader didn’t show up any more.
I am running latest steam version.

Yes, The “Traveling” trader who asks for x amount of crafted items for x amount of goods fails to complete, here is the error after the screen to show it was listed, before it timed out another merchant arrived, it’s the one at 23 hours:

The Error when times up:

Windows 7 Home Premium 64-Bit
Alienware R4
16GB RAM
Intel® Core™ i7-4820 CPU @ 3.70GHz 3.70GHz
Graphics:
GeForce GTX 760 (2)

Addendum: If you do NOT complete the order for the traveling merchant you do get the normal “Oh I see you don’t have what I asked for” completion.

Either download it from Humble Bundle and then don’t update it or set Steam’s update settings to “Only update this game when I launch it” and then directly launch it from the executable. That way you always have the same version.

A softer approach would be to opt out of the latest branch, which is promoted as “unstable” more than enough.

i cant confirm this 2 games every over 11 day and he still approches … but for this i dont get goblins or the shops xD

Wow an old post to respond to, long solved.

But thanks for the advice :slight_smile:

1 Like

It’s less solved than I would want it to be… Steam seems to have removed the option to opt-out of updates completely. Which would be really handy in this case.

There’s of course also the Euro Truck Simulator 2 kind of way to deal with it - i.e. create Betas for every last build of a stable branch so mods/save games continue to work. But I don’t think that’s justified for Alphas either. Well, not really…

Sorry at work so my post was a bit short, fixed for me, I found a process when presenting my videos that allows me to “control” when I have updates. Save seem to work across multiple versions more often now (with small bugs) as well which is helpful.

Ya I agree, I wish I had much more control of the steam updater for Stonehearth, but alas we are in the minority. I assume most users don’t even know about the beta options available, so Steam is unlikely to add this functionality.