Auto tracking resets to never

Just as the title says whenever I change my preferences for auto tracking to something other than never it resets as soon as I leave the page or refresh. This is irritating because it seriously impacts my tracking of unread topics when they don’t show up as unread.

Hey Xavion,

The same thing happens to me but even though the box says ‘never’, topics for me are automatically tracked as soon as I enter them.

Try going into a new topic, going out of it, and then going back in and seeing if the option at the bottom changes from ‘regular’ to ‘tracking’

As for why the option doesn’t remain, that would be something for @system or @system to answer.

I’ve checked and it doesn’t auto track when viewing, so it seems that it actually is set to never and it’s not just lying. It does however track when I reply so not everything’s broken.

Hmm, my setting was previously on automatically before the update, so perhaps that setting is still applied for me?

Mine was previously set to always as well but it changed at some point and now I can’t change back.

Yer I’m really not sure then!

I guess we’ll have to wait for one of the discourse guys to comment on it, you could try messaging them, or posting on [url] [/url], just in case it’s an issue all around?

Possibly a bug that might have already been fixed. I can’t repro on anyway.

@system will update the Discourse version to the latest soon!


It works now! It changed to 4mins with the update but now it’s set to always. I can see one problem however, it’s retroactive. I now have 127 unread threads, oh well time for some trawling.

Oh god. I hope I’ve kept on top of mine … this could be painful

Oh, never mind, it’s set to always. YES!

Setting tracking to “always” is not something I would do lightly. There is a reason the default tracking is 4 minutes of reading, or a reply to the topic.

If you do set tracking to “always”, it means you commit to reading every topic on this forum, for the forseeable future and all of the past. It’s definitely hard core.

@codinghorror Nice to know… just switched it to “always” :see_no_evil:.

As of now, it’s reasonably manageable, I do it just to keep tabs on everything make sure it’s all running fine and everybody is abiding by the rules. Think of it as a single man police state.

If/ when things get busier I will probably change it so I don’t have to be on 24/7 or risk having a constant number next to posts!