Alpha v22.5 won't start

resolved

#1

Summary:

Game won’t start. Steam will stay in the “running” status for a couple of seconds then it’ll eventually go back to “idle” status

Stonehearth.log:

2017-11-11 17:01:02.285054 | server | 1 | app | Stonehearth Version 0.22.5.763 (x64)
2017-11-11 17:01:02.323057 | server | 1 | core.config | user id is 3819b1fa-bcb1-11e7-a792-002421f319ee
2017-11-11 17:01:02.323057 | server | 1 | core.config | session id is 83fff49c-c6f9-11e7-887c-002421f319ee
2017-11-11 17:01:02.334057 | server | 0 | core.system | Initializing crash reporter
2017-11-11 17:01:02.378063 | server | 0 | lua.data | lua jit is disabled
2017-11-11 17:01:05.593434 | server | 1 | resources | Modules are verified pristine.
2017-11-11 17:01:06.142492 | server | 1 | app | Running Stonehearth server on port 15430
2017-11-11 17:01:06.175496 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2017-11-11 17:01:06.334514 | client | 1 | game_engine | Initializing OpenGL
2017-11-11 17:01:06.415524 | client | 1 | game_engine | Determining window placement
2017-11-11 17:01:06.415524 | client | 1 | game_engine | Selecting monitor at 670, 390
2017-11-11 17:01:06.415524 | client | 1 | game_engine | Creating OpenGL Window

Versions and Mods:
Alpha 22.5, vanilla.

System Information:

Windows 10; AMD Radeon R7 200 Series;

Notes:
I’ve already tried both to boot it as admin, the compatibility thing. Just nothing works, and I can’t also find a Crash.dmp file anywhere
By the way, the game used to work on this pc in an earlier release (I don’t know which,though.)


#2

@max99x might have an answer for you?

Otherwise, maybe try a completely fresh install if you haven’t already.


#3

@LingFox, have you tried updating your graphic drivers from http://support.amd.com/en-us/download ?

Also, the fresh reinstall? (Backing up the savefiles and templates, deleting manually the Stonehearth folder and reinstalling through Steam)


#4

Yes, I already tried with a clean install, both stoneheart’s and the driver’s.

I once noticed (and edited) in the stoneheart.json file that the resolution was 1920x1080 (and my monitor only supports 1440x900)


#5

Could you try running in 32bits? Find "force_32_bit" : false, in your user_settings.json, and change it to true. Save it and then start the game.
Also try with changing "enable_fullscreen" : true, to false, if you were playing in full screen, although I doubt that’s the issue.

Which antivirus do you have? It might be conflicting with the game :confused:


#6

It used to conflict but I resolved it - It’s comodo.

It’s try this one right away and then edit the post with the results :slight_smile:
EDIT 1: Haven’t found the Force 32 bit line, I added it in the renderer settings - The game still doesn’t work.


#7

No, it doesn’t go inside the renderer settings. Try placing it at the same level than your user_id, for example:

{
	"user_id" : "your_user_id",
	"force_32_bit" : true,
    ... (rest of your user settings) ...
}

#8

Sorry if I bug you, but the only thing I see in the stonehearth.json is this:


#9

@Relyss requested/suggested you to make changes into user_settings.json, not stonehearth.json :slight_smile:


#10

Silly me. Ok, trying.

Tried that, doesn’t work. Should I force the 64 bit?
EDIT: Tried to force the 64 bits, still doesn’t start. Also, if I add the line without quotes, the game will just crash. (and when I add those the game won’t start anyway.)


#11

You need to end every line of a block with a comma, except the last one. Else the code thinks it is one single command, that is what this last error is about.


#12

Done. But still nothing. - But now it works. I don’t know why or how , it just works. Maybe it was a broken update for me.