[Alpha 7] Bug: Wall-Mounted signs in blueprints not placeable?

Hey guys not sure if this is an issue or if this expected. When trying to place a wall-mounted sign in my blueprints I can’t place wall-mounted signs in certain areas. It would be nice to be able to have it placed in the blueprint so that i don’t have to place them separately…and it would be nice to have blueprints for certain crafts. This is on the latest steam branch.

Steps to reproduce:

  1. Craft a wall-mounted sign.
  2. Start a building blueprint.
  3. Try to place a wall-mounted sign
    . .

Expected Results:
Wherever you wish to place the sign in the blueprint it appears

Actual Results:
It seems to appear only in specific areas…not sure the reason for it

You can see this happening in my video below

hmm… I think it has to do with the placement of the building itself…

notice the red lines around the perimeter? I think it means the building is encroaching on surrounding objects (bushes, etc.)… try placing a building in a completely open space and see if you have the same issue adding banners…

Even if I wanted to place it over the door? That’s where I wanted to place it originally. I’ll try it out quick.

I tried to place it after the building was mostly completed and it appeared acceptable

I tried with a new building and no obstructions

hmm… that’s peculiar… I know you’re unable to place items like windows right next to a building edge, but I haven’t seen an issue with placing signs… and you’re unable to place the sign in the larger open space above the door and window?

If you watch the gif you can see I go above the door…now if you mean the area more in the roof I tried making a whole new house.

I noticed that the door didn’t want to place when using the furniture tab however when I use the doors/windows tab it placed. Maybe it’s related to all decoration items? Or that tab?

Sorry if that’s a lot of gifs…I like animations so you can see the issue and I was having issues getting the gif to be small enough