Alpha 18 crashes entire computer (resolved by disabling fullscreen)


In all honesty, the crash did not happen to me. I just gifted the game to my friend on Steam and he cannot get it to run at all. He has three monitors, which he thinks might be the problem, but he didn’t feel like trying to fix it so I’m filling out a report for him.

So, when he tries to play the game, what basically happens I believe is: All three monitors turn black (not off, but displaying black), his cursor vanishes, his computer stops responding and then crashes entirely. He tried it again after updating his graphics card driver and got a blue screen this time.

I would like to note that he did try all the troubleshooting steps and nothing worked. We also have come up with two possible causes, and would like to see if anyone has experienced the same thing.

Idea 1: I had the idea that his 3 monitors might be the issue, based on the black display that occurs before the crash. I kind of recall having minor problems with my 2 monitor set up, but nothing bad enough to crash my entire computer, so who knows.

Idea 2: My friend, the tech nerd he is, mentioned that Windows 10 and NVIDA graphics cards tend to not really get along well. “Why do you have them then,” I ask. “Because that card is more expensive than the rest of my computer combined,” he answers. “Nerd,” I retort. All that aside though, it sounds like it could be a factor, I’m not sure.

[details=Stonehearth.log]2016-08-21 20:33:50.433859 | server | 1 | app | Stonehearth Version (x64)
2016-08-21 20:33:50.434359 | server | 1 | core.config | user id is fd79b402-67ff-11e6-9aa4-00ffa2f58142
2016-08-21 20:33:50.434359 | server | 1 | core.config | session id is 18a80b0c-6800-11e6-b69b-00ffa2f58142
2016-08-21 20:33:50.439864 | server | 0 | core.system | Initializing crash reporter
2016-08-21 20:33:50.947034 | server | 0 | | lua jit is disabled
2016-08-21 20:33:50.971206 | server | 1 | resources | Module rayyas_children_ui version 2 is deferred load)
2016-08-21 20:33:52.095404 | server | 1 | resources | Modules are verified pristine.
2016-08-21 20:33:52.128040 | server | 1 | app | Running Stonehearth server on port 49711
2016-08-21 20:33:52.128040 | server | 0 | physics.navgrid | subspace pathfinder is enabled
2016-08-21 20:33:52.128040 | client | 1 | renderer.renderer | Initializing OpenGL
2016-08-21 20:33:52.136037 | server | 0 | mod radiant | setting controller lifetime tracking debugging mode to “create” in developer build.
2016-08-21 20:33:52.136037 | server | 1 | mod radiant | lua controller lifetime tracking set to "nil"
2016-08-21 20:33:52.145546 | server | 0 | mod | [] enable_cpp_compound_action is on
2016-08-21 20:33:52.153567 | client | 1 | renderer.renderer | Determining window placement
2016-08-21 20:33:52.153567 | client | 1 | renderer.renderer | Selecting fullscreen monitor at 0, 0
2016-08-21 20:33:52.153567 | client | 1 | renderer.renderer | Creating OpenGL Window

Versions and Mods:

Alpha 18, no mods

System Information:

Windows 10, NVIDA GeForce GTX 980 4GB MSI Twin Frozr, 3 monitors

[details=Full Computer Specs (This thing probably costs more than I make in 6 months, his computer can absolutely run this game)]NVIDA GeForce GTX 980 4GB MSI Twin Frozr
24" ASUS 144hz 3D monitor
Intel i5 4960K - water cooled and overclocked
mobo Z97M MSI
16GB ram
SSD and HHD drives (2.6 TB total)
600W PSU
ASUS 802.11AC 1.3Gbps wifi router [/details]


Again, this isn’t my computer! I’m keeping in touch with him though, so I’m sorry for any delayed responses.

ok the specs looks great but its interessting that it crash the pc when its try to open a opengl window … have you the actual drivers installed? can you try it after reinstall again?

here NVIDIA Treiber Download

He just updated his driver last night actually, I made him do it before I submitted the report. The only difference it made was giving him an actual bluescreen before it crashed.

ok ^^ can he try the unstable build because he plays with stable17 (Stonehearth Version (x64))^^

but best before that complete delete the stonehearthfolder manually in his steamfolder and then reinstall and change to latest branch

Ok, I’ll tell him as soon as he gets online. Thanks!

1 Like

@Wiese2007 he did everything you said and even updated his drivers again just to be sure, and he’s still crashing. Hopefully he’s going to make and account soon, i think hes doing it at this moment actually.

ok he shall write here then - so a dev can look into it :smiley:

Yep, he had to run out and do something, but he wanted to test a couple more things before saying anything, sorry for the wait

1 Like

Can he try with just one monitor connected and see if it works?

1 Like

Hey, actual user with the problem here. I tried reinstalling the game 5-6x and no luck. Also reinstalled the Nvidia drivers twice with GeForce Experience and installed from the Nvidia website twice. I even reinstalled steam

I tried running one monitor from intel graphics (disabled GPU in BIOS) and got bluescreens on startup. The issue may be something to do with my overclock.

I got the game to work by editing the .json file with the settings and disabling fullscreen mode. I am still unsure the exact cause of the problem


@jordankothe9 welcome to the discourse, took you long enough :stuck_out_tongue:

1 Like

It’s known that sometimes graphic boosters (or in your case may be the overclock) can cause the game to fail to start.
Have you tried both 32 and 64 bit versions? (There’s a switch in the user_settings file).

I have Windows 10 and NVIDIA graphics, and I never got a problem like this (but I only have 1 monitor).

I’m glad that at least the window mode works for you in the meantime.

1 Like

heyho can you try to start it manually from the stonehearthfolder (so its start without steam) and without mods form other persons