Alpha 16 - Build 2924-2938-2940 - Bug to change Herbalist Level 6 to Cleric from old save game

resolved

#1

Summary:

Since Alpha 16 this heartling cannot be a cleric or other class without bug
This heartling is bugged and appear naked.

develop-2924 (x64)
stonehearth/components/job/job_component.lua:368: bad argument #1 to ‘ipairs’ (table expected, got nil)
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
[C]: in function 'ipairs’
stonehearth/components/job/job_component.lua:368: in function '_remove_all_perks’
stonehearth/components/job/job_component.lua:380: in function 'demote’
stonehearth/components/job/job_component.lua:238: in function ‘promote_to’
…s/server/town/orchestrators/promote_orchestrator.lua:71: in function ‘_change_job’
…s/server/town/orchestrators/promote_orchestrator.lua:22: in function '_trigger_cb’
radiant/modules/effects/trigger_effect.lua:14: in function 'fn’
radiant/controllers/nonpersistent_timer.lua:56: in function 'fire’
radiant/controllers/time_tracker_controller.lua:82: in function <radiant/controllers/time_tracker_controller.lua:82>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/controllers/time_tracker_controller.lua:82: in function 'set_now’
radiant/modules/gamestate.lua:9: in function 'set_now’
radiant/server.lua:61: in function <radiant/server.lua:58>

Steps to reproduce:

  1. Old save alpha 14 change this old herbalist level 6 to a fresh cleric

Expected Results:
Change Class without problem (please no naked i’m shy for my old age lol)

Actual Results:
Savegame :

Notes:
No mods and Old save from Alpha 14

Attachments:
logs : http://www.sendbox.fr/818cf35e47ea323c/stonehearth.log
savegame : http://www.sendbox.fr/d19a8777ae0722c4/1460595408482.zip

Version Number and Mods in use:
a16 build 2924

System Information:
Windows 10 Pro
Intel I5 + 4Go RAM + 240Go SSD


Bug: Cleric Promotion Doesn't Promote
#2

Hi,
Can you please upload your A14 save? (before he became naked)?
Thanks
-Yang


#3

I’m uploading right now i edited my post to not loose all i did lol


#4

Upload done sorry if i don’t post all in one shot :wink:


#5

Yang I have a big question ^^
Did you receive my bugs (logs) when i check in first game start “send bug report” ?
I really hope coz sometimes specially last time i didn’t post a bug for building.
I will try to redo this bug and past it in the forum.


#6

I’m seeing some promotion oddities too when working with a pre-A16 save (zip).

  • After crafting the knight and archer talismans for the first time, they showed up categorized as Weapons but were not recognized as valid talismans by the promotion UI. Tried everything (removing them from all storage, demoting footman to worker and back again, etc). No dice. Finally made a second set of talismans and those were categorized as Tools, and we’re usable for promotion. The Cleric talisman worked properly the first time.

  • Ran into a situation where my Shepard just stopped shepping and went idle. Reloaded the save. Demoted her. Tried to promote her back again, but the UI couldn’t find her talisman anymore, even though the requirements text was green. So I made another talisman, and the new one enabled the Shepard button on the tree, but did not display the promotion stamp button. …So I can’t re-promote my Lvl6 Shepard at the moment.

Seeing other inventory related strangeness too. Gate placement requests that never get fulfilled, while other objects are placed fine. Perhaps related to the talisman issues. Not sure? Maybe something to do with the auto-door replacement stuff related to door damage? Just thinking out loud.

@8BitCrab, @jomaxro and/or @Relyss, can you help sanity check me on all of the above with my linked save too? I don’t want to send Yang on a wild goose chase if it’s not reproduce-able by others.

Screenshots:


Paging @sdee and @yshan as a bump to ensure visibility.


#7

Can confirm this. Just stumbled onto this bug after updating to 2924. My saves are from build 2922 (started a new game), so they are not very “old”. Seems like the bug occurs with any saves made prior to build 2924.


#8

This bug is also under last dev 2940 of course only with old save game (save game from alpha 14 to alpha 15 and into this new awesome fresh one alpha 16)
I’m just gonna try to build a new talisman and no more concern about this bug or maybe try a new game old save game gonna break one day :wink:

This savegame :
http://www.sendbox.fr/9271efc7669f7c01/1459381922906.zip


#9

I tried making a new talisman and still couldn’t promote them. I’ll be curious to hear what happens in your case.


#10

same result now i’m destroying all mly talsiman and try it and my last resort it’s gonna be new game or destroy my hearthling lol


#11

Or maybe i mistursdand you XD
I’m talking about to destroy all my herbalist’s staff and book


#12

OK each time i try to change this heartling i’ve got the same message error :wink:


#13

Even if i’m changing him into a worker he take the outfit’s worker but into his job name he appaear to be a “master herbalist” and yes he do nothing just eat and sleep and some other things if i remember.He’s my precious :wink:


#14

And another bug with this : the herbalist crafting orders is bugged with this.The first thing you craft the next herbalist cannot craft it only the second item can be crafted :wink: (my brain gonna explode too much english lol)


#15

talisman = tools, right ?


#16

Hi!
I downloaded the save game you linked and created a cleric tome and was able to upgrade your herbalist to a cleric. The cleric has the correct clothes, etc.
I’m wondering if this is like a graphics driver issue. Would you mind trying a clean install of the game and see if the naked cleric bug still happens?
Thanks
-Yang


#17

You take my litte master herbalist level 6 ? OK let me test it into another computer with a nvidia gpu card


#18

Oh wait, sorry I loaded a different save.
Okay I got your save and I have a fix for it. Will be in next unstable release.
Sorry about that!
-Yang


#19

Same with nvidia card without uninstall but kobold ai stuck error during crypt spawn ai throttle this bug two times since alpha 16 2940 i don’t have save a screenshot coz this computer he’s a slow one.
Did you know this directory “animations” left even during uninstall with stream client ?


#20

kobold archer can’t attack crypt’s build like heartling archer like in the past build alpha 16 build 2938