Alpha 14 Breaks Frostfeast mod?

Title: Alpha 14 changed mod API

Summary: Loading FF that works in Alpha 13 no longer work in Alpha 14.

Steps to reproduce:

  1. Load stonehearth vanilla, with one mod, frostfeast
  2. Try to start a new game
  3. Receive an error

Expected Results: Being able to start a new game

Actual Results: Some error prevents this.

Notes: Mods no longer have .LUAC files, but LUA files. Radiant mentioned they tweaked rc, so i wonder what about custom kingdoms has changed.

Attachments: FF Errors:
develop-2786 (x64) radiant/modules/events.lua:86: assertion failed! stack traceback: [C]: ? [C]: in function 'assert' radiant/modules/events.lua:86: in function 'listen' frostfeast/ai/observers/hat_observer.lua:19: in function 'activate' radiant/modules/common.lua:397: in function 'create_controller' ...ehearth/components/observers/observers_component.lua:50: in function '_create_observer_controller' ...ehearth/components/observers/observers_component.lua:61: in function 'add_observer' stonehearth/services/server/ai/ai_injector.lua:57: in function '_inject_observers' stonehearth/services/server/ai/ai_injector.lua:44: in function '_inject_ai' stonehearth/services/server/ai/ai_injector.lua:14: in function '__user_init' radiant/lib/unclasslib.lua:270: in function '__init' radiant/lib/unclasslib.lua:201: in function 'AiInjector' stonehearth/services/server/ai/ai_service.lua:147: in function 'inject_ai' stonehearth/components/ai/ai_component.lua:62: in function <stonehearth/components/ai/ai_component.lua:45>

develop-2786 (x64) c++ exception: lua runtime error stack traceback: [C]: in function 'create_entity' radiant/modules/entities.lua:24: in function 'create_entity' in function 'create_new_citizen' ...vices/server/game_creation/game_creation_service.lua:377: in function '_generate_citizen' ...vices/server/game_creation/game_creation_service.lua:74: in function <...vices/server/game_creation/game_creation_service.lua:60>

develop-2786 (x64) ...rostfeast/components/breather/breather_component.lua:20: attempt to index field '_entity' (a nil value) stack traceback: [C]: ? ...rostfeast/components/breather/breather_component.lua:20: in function '_on_warmth_changed' ...rostfeast/components/breather/breather_component.lua:9: in function <...rostfeast/components/breather/breather_component.lua:8>
Version Number and Mods in use: Frostfeast or any kingdom mod besides RC

System Information: Windows 10 64 bit, Nvidia 750m, Intel core i7

Not really a bug with the game. Frostfeast is most likely over!


@Froggy its the same with alll mods with observer like cookmod, candledark, brewery and homf :wink:

Yup, I saw Yangs stream the other day that explained the lua changes.

My prior statement was my subtle way of saying it’s a problem with the mod, not the game, and it’s unlikely to be fixed.


and whats with my beloved cookmod? :anguished:

1 Like

Dunno. Not looked at it yet :]


When most games (I don’t actually know about Stonehearth, but since @Froggy posted about it I assume also) are updated, mods break. Then the mods have to be updated. Pretty much how it works. You’ll just have to take out the mods until they are updated (if they will be updated at all) for Alpha 14.

1 Like

moment, for me game version 491 is the latest, this is alpha 13. This there something i miss?

I stop looking at the page for one day and now there is a new version. cool. But in steam i still get the v491, not the alpha14. strange. Hops this is just a temporary issue.

Refer to “About Latest Branch” @


thanks froggy. now it works as expected.

1 Like

Ahh, sad to hear but understandable. Thanks froggy :slightly_smiling: