[ACE] Pre-Release 0.9.3.3 - The Quality Update!

That’s the problem it’s not giving me the choice to unpack or destroy them even at full health. Sorry for petulant complaining I just would like to help.

2 Likes

You mean you can’t use the destroy tool and drag a box over them?

Yes I have tried.

Oh, interesting. I’ll take a look!

And hey, don’t apologize :merry: we literally ask people to always report issues/bugs, so that is good! :jubilant:

2 Likes

Hello there. I don’t know if this as been discused yet or am I the only one having the following issue : As soon as a crab trap is placed, my fisher will become idle and will do literaly nothing, even eat or sleep. The only way to make him have a “normal” life again is by removing any crab trap. Anyone else noticed it?

Ho, and by the way : ACE mod rocks guys! Thank you sooooo much for this amazing work! :grinning::heart_eyes:

3 Likes

The Fisher and Crab Traps are part of Bruno’s awesome Archipelago Biome Mod! The issue might (or might not) be related to ACE but to make sure it’s nothing else (or another mod), try loading your save without ACE (it will break a lot of things, but should load) and see if your fisher remains stuck.

Alternatively, it could be some other things like placement, etc… But maybe you should give more details there :slight_smile:

Looks like I was not the only one having the issue. It has been resolved with an update of the Archipelago mod by Bruno. Thank you. :merry:

1 Like

I’ve got 3 issues:

  1. My game crashes when i try to load my last save1556468764265.rar (6.8 MB)
  2. I was able to load and play last autosave, but now game crashes after some time (5 - 15 minutes of playing)
  3. When i turn on the water pump it shows me as working but not realy pumping the water, but seems become working when i save and load game

Just started playing around with this and I can’t seem to get hearthlings to use supply tables. They always wander off into the wilderness to get resources even with the “prefer high-quality crafting ingredients” unchecked.

are there red exclamationmarks above the supply tables?

I’ve read a bunch of comments like this, I think the modders are aware of it too, and it will probably be fixed for the next update.

1 Like

I don’t know why The worker not wear the worker Outfit,however,They only wear anther kingdom’s worker Outfit



The anther problem is Pet don’t eat any kibble in bowl or Stockpile.
How to kill the fish in lake? It can’t be killed by archer

There is indeed an error with the Northern Alliance Upgraded Worker Outfit. Just found it - thanks for the report! It will be fixed for the next version.

Huh! There seems to also be an error there. Testing it right now. Thanks, will also be fixed! :smiley:

Right now you don’t have any means to kill fish, well not any easy means anyway. If you remove them from the water they’ll die.

There are fishing traps coming soon, though - then you’ll have a way to kill fish!

Thanks for all the reports :slight_smile:

4 Likes

Just a question about ACE…

I have played now for a long time vanilla game and tried to keep playing in spite of some annoying buts remaining in Stonehearth.
Two of them I find game breaking (maybe not directly, but though…) made me stop playing, frustrated, deceived and a bit furious.
I didn’t want to try ACE not to add new bugs to the already existing ones.

These two bugs are:

  1. Water problems appearing after a certain time in game when using wet stones: water falls appear to “fall” on and off and even without any wet stone, I get engine errors about “water-component” (didn’t look at details) after playing a somehow long time (relaunch doesn’t help, the error even comes at launch. Just close it and play further…
    2.When I reembark saved hearthlings in a game with Rayya’s children, most recipes are not kept in the new game, when everything is ok with Northern Alliance. My goal is to unlock all kingdom recipes, but obviously it doesn’t work properly.

So my question:

Does ACE keeps the mechanism of reembarking and corrects this problem of lost recipes?
As water has been reworked, has the other problem been taken in account (if ever known…)
To conclude: Can you correct certain remaining bugs of vanilla game?

If the answer is yes, I’ll activate ACE and report bugs (ACE ones and others) here to help you as much as I can.

Thanks for reading and hopefully answering.

As far as the water issues:

the ACE team realised that more wet stones = more that can potentially go wrong, and they added a “natural” wet stone which can replace the large number of wet stones used in many landmarks with a single, high-output one which creates much less water calculations overall.

Messing around with wet stones myself, I found the same issue – no matter how many you use, eventually their flow just drops and drops (probably related to the fact that they will only produce water when they’re not already surrounded by water; so if you have a lot then there’s a “random spawn” mechanic like in a Game of Life/cell simulator where wet stones will eventually get over-crowded and stop creating water until the local amount drops)… this is mitigated if you a) use the large wetstones instead of a lot of small ones, and b) have the water immediately move away from the wet stone into some kind of hidden reservoir which feeds into the visible body of water that you want to keep filled.

We really need a “bulk” wet stone which creates a whole block’s worth of water every tick if we want waterfalls which don’t drain down to a trickle of water after a few moments. Sadly, because of how the water simulation in Stonehearth works (i.e. there’s no angles to the terrain so the water itself forms an angle downwards as it spreads out; rather than maintaining a constant surface height as it usually does IRL), the only way to achieve a realistic looking river flowing into a waterfall is to have a hidden “cap” at the end of the river to hold its volume in place, and then have a wet stone somewhere to generate the spill-over water… so it’s more like a fountain than a waterfall.

I guess that some “fake water blocks” might be another good option – build them at the end of a river so they keep the river full but let it look like the whole volume is flowing when it’s really just that tiny spill-over volume. Of course, if we go that route we might as well get fake waterfall blocks too; and circumvent the issues with flowing water altogether if it’s just for decorative use (if you want water somewhere e.g. for farming you can use a pump from ACE or a wet stone to just create it where you want it; if you want to have a nice river and waterfall to explain how it gets there then you can fake the waterfalls and keep the rivers full with a static amount of water so that there’s barely any calculations involved.)

1 Like

Hi, just unlocked heirblooms on my latest game and I’m getting an error when trying to select crops. Clicking on a field causes the below error message, the I can see what crop is in the field, but not the crop growth pane and whilst I can bring up the crop selection menu it’s empty. Reloading the game doesn’t seem to help either. I’ve loved the update so far, hope you’re able to fix this in the next release!

release-949 (x64)[M]

Uncaught TypeError: Cannot read property ‘plant_water_affinity’ of undefined
TypeError: Cannot read property ‘plant_water_affinity’ of undefined
at n._selectedCropUpdated (http://radiant/stonehearth_ace/ui/game/modes/zones_mode/farm/farm.js:310:111)
at w (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:23160)
at m (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:4:21029)
at b (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:13753)
at a (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:12519)
at h (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:13415)
at a (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:12507)
at y (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:5:17298)
at n.set (http://radiant/stonehearth/ui/root/js/libs/ember-1.8.1.min.js:8:25617)
at n._setModel (http://radiant/stonehearth/ui/root/js/stonehearth/view.js:157:15)

1 Like

The Farmer not use fertilizer to wheat
I think anther crop also not use it


If they equip any Worker’s tools and Backpack,they will not wear any worker outfot



I can’t seem to reproduce this issue here… I levelled up a farmer, made some fertilizer and they are fertilizing wheat normally. Make sure that you don’t have “None” selected for the fertilizer choices above the “specific fertilizer” choice.

Also can’t seem to reproduce this one. But I see it’s summer in your game, they won’t want winter (or any other very warm) outfits during the summer. You need regular worker outfits.
Yes, this is intended - to make the regular outfits more worth it. Previously, since their bonus is the same as the winter outfits, they were basically useless (and it was better to just have winter outfits). Now hearthlings will prefer to not use winter/warm clothing in the summer/spring.

Edit

Ah, this one is caused when a crop has no ACE farming data! We forgot a ~nil check to prevent it happening (so it’s compatible with older mods, etc…) and that is already fixed in the Unstable version. It should soon be fixed on the steam version! But if you wish to fix your game right away, just get the unstable version and enjoy that (and many other) additions and fixes already in!

2 Likes

in the last screenshot I am seeing what appears to be 2 red upgraded worker outfits

The red ones are RC winter worker outfits. There are several other varieties of cold/winter outfits there, no normal ones.