[ACE] Pre-Release 0.9.2 - Out now!


#282

I’m playing via the Steam workshop version but it says I have V0.9 installed not v0.9.2


#283

I’d also like to see the Amberstone clan a complete playable race.


#284

So many people do that there’s a separate project on that already. We could use some help with missing animations.


#285

I’ve seen one Clan Amber stone mod project like that but it’s just a reskin of Nothern Alliance with a lil remake of the start of the settlement thingy…


#286

There’s an in-game workaround… assign a “bin” that takes rotting food and nothing else, and ensure all other containers don’t allow that holding of “garbage” items.


#287

Playing on Steam and ACE is NOT downloading for me, or showing up or anything. Just nowhere to be found. Any suggestion how to get it?


#288

Steam Workshop :: Authorized Community Expansion (ACE) for ACE in the Workshop.

and you should have that.

edit : Did you select the latest build in the section Beta in steam properties ?


#289

Thank you, Navarth. No, I am not subscribed to any beta, just the regular version. And I will try to get the mod manually then. I was confused since the ACE article on Steam stated that the game should get everything for ACE automatically.


#290

It automatically make you follow ACE in the workshop, but you still have to switch it on, i don’t know if you really need to be on the latest build in the beta properties tho (since i haven’t been on the normal version).

If nothing works it might also be steam fault (i did have problem with mod who were unable to be downloaded/updated or properly installed in others games)


#291

it would be amazing if you make this full on industrial revolution.


#292

@Wouter_Sikkema or @BrunoSupremo I know you both have a mixinto in your mods that says something like “stonehearth_ace/manifest.json”: “box_o_vox/ace_manifest.json” and was wondering if that actually works? I tried to both mixinto & override one of my own recipes for when ACE is present it’ll use “bone resource” as it’s ingredient instead of “pelt resource” but I’m not seeing the change once I load up the game. it’d be nice to have it work.


#293

That didn’t worked for me. :frowning:


#294

darn, I suppose I could say ACE is a required mod for when playing mine but that doesn’t stop people from disabling it in game if they for some reason didn’t want to play with ACE (what madness?!!? haha)


#295

Maybe you could add a second recipe with the changes, for example, your folder would contain:

my_recipe.json
my_recipe_ace.json

And then just add a mixinto to the recipes.json file inside ACE for that profession, changing the recipe but using the same recipe key in the file, like

"recipes": {
    "my_recipe": {
          "recipe": "/yourmod/jobs/job/recipes/my_recipe_ace.json"
    }
}

Maybe that could work? Unless the recipe belongs to one of your custom jobs… in which case a mixinto doesn’t work but maybe an override could? You override your own recipe file with the ACE version, for example?


#296

I have a setup like this, I’m not 100% clear what you meant in your reply. inside the ace folder are duplicate recipes that instead say “bone resource”
Untitled
Untitled


#297

And how are you telling the game to use these instead of the default ones when ACE is active?


#298

trying the way I saw in Bruno’s and Wouter’s mods. by putting this
“stonehearth_ace/manifest.json”: “box_o_vox/ace_manifest.json”
into my manifest mixintos


#299

then from there I’m saying to override my normal ones with the ones inside the ace folder. currently doesn’t work.


#300

only thing I could think of is if you, yourself, add some bit within the ACE manifest like this:
"overrides": { "/box_o_vox/jobs/necromancer/recipes/skeleton_gatherer_recipe.json": "/box_o_vox/jobs/necromancer/recipes/ace/skeleton_gatherer_recipe.json", "/box_o_vox/jobs/necromancer/recipes/zombie_miner_recipe.json": "/box_o_vox/jobs/necromancer/recipes/ace/zombie_miner_recipe.json", "/box_o_vox/jobs/necromancer/recipes/necromancer_mask_1_recipe.json": "/box_o_vox/jobs/necromancer/recipes/ace/necromancer_mask_1_recipe.json", "/box_o_vox/jobs/necromancer/recipes/necromancer_mask_2_recipe.json": "/box_o_vox/jobs/necromancer/recipes/ace/necromancer_mask_2_recipe.json" }
and then maybe it would work… I’m going to try a test on my end…

that’s asking a lot though.


#301

BUG REPORT

I’ve seen this error with different animal pets, different factions, different biomes, and with no mods except ACE turned on. Essentially seems to be an issue with the animal sitting animations not being called properly.

Bug Details

release-949 (x64)[M]
c++ exception: invalid file path ‘/stonehearth/data/rigs/entities/critters/beetle/effects/sitting_drink.json’.
stack traceback:
[C]: in function ‘load_json’
radiant/modules/resources.lua:34: in function ‘load_json’
radiant/modules/effects/effect_manager.lua:73: in function ‘get_effect_json’
radiant/modules/effects/effect_tracks.lua:38: in function ‘__init’
radiant/modules/commons.lua:22: in function ‘EffectTracks’
radiant/modules/effects/effect_manager.lua:159: in function <radiant/modules/effects/effect_manager.lua:156>
(tail call): ?
(tail call): ?
(tail call): ?
stonehearth/ai/actions/run_effect_action.lua:73: in function <stonehearth/ai/actions/run_effect_action.lua:47>
[C]: ?

…nehearth/services/server/tasks/task_group_action.lua:137: in function <…nehearth/services/server/tasks/task_group_action.lua:125>
[C]: ?
[C]: ?
[C]: in function ‘run’
stonehearth/components/ai/ai_component.lua:549: in function <stonehearth/components/ai/ai_component.lua:533>
[C]: in function ‘xpcall’
radiant/modules/commons.lua:67: in function ‘xpcall’
stonehearth/components/ai/ai_component.lua:533: in function <stonehearth/components/ai/ai_component.lua:529>
[C]: ?
[C]: ?