(A22) So I tried to put a roof on this Engineer's Building I made

Kinda my complex personal building I made for my engineer. Tried to simulate “gear” decos with just slabs. :confused:

When I tried to add a roof to the lower floor of my Engineer’s Building by hovering my roof tool on the left side of my “Engineer’s Building”, suddenly I get an error message pertaining some sort of engine error. After that, it seems like I can’t add roof on that side of the building anymore. However, the tool is not completely broken. I can apply roofs to any other buildings with enclosed wall spaces. That space was also enclosed so

I just closed the error window on a whim and just kept constructing my building up to the second floor. I had to restart my game and reproduce the bug again just so I can show the bug again…It was a good thing it’s there. Suspectibly a bit different though.

Sigh. So for now on, I had to manually add that roof by using slabs. Which, however, creates an unintended visual effect for slabs since the “roof” was built through slabs.

Steps to reproduce:

  1. Create first floor walls on a foundation floor.
  2. Partially cover a portion or about half of the top using the floor tool.
  3. Create second floor walls
  4. Create decorative slabs on the walls outside the building, 6 blocks high as the walls.
  5. Attempt to apply roofing on the first floor (hover mouse over wall).

Expected Results:

Actual Results:

As I said before, this happened before I built the second floor on the right side of the building. Perhaps it’s probably all of those slab corners I built? Even though they were level with typical wall height (6 blocks)? Or maybe it’s the roof overhang that’s causing this? They were all set to 1 and I kinda overlooked it before applying the roof.

Also, the walls were “free-standing” types, not auto-generated. Just so that I can achieve a proper “lumbered” building aesthetic.


Version Number and Mods in use:
release-763 (x64) | No mods (Vanilla)

System Information:
Windows 10 64 Bit | AMD FX™-6300 | 16GB RAM Memory | EVGA NVIDIA GeForce GTX 960 4GB ACX 2.0

5 posts were merged into an existing topic: Engine Error - Assertion Failure